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1 Introduction 
1.1 About this Manual 

This manual provides information on how to set and configure the device 
parameters of a netX based EtherCAT Slave device within a FDT 
Framework using the EtherCAT Slave DTM, and what can be read from the 
diagnosis panes. 

In a network project the EtherCAT Slave DTM can be dropped: 

• to the root line (Stand-Alone Slave), 

• or to the Master busline of a EtherCAT Master DTM. 
 

 
Note: This manual edition first provides information for the case if the 
EtherCAT Slave DTM is dropped to the root line (Stand-Alone Slave) and 
in addition important information for the case if the EtherCAT Slave DTM 
is dropped to the Master busline of a EtherCAT Master DTM. 
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1.1.1 Descriptions of the Dialog Panes 
The table below gives an overview for the individual dialog panes 
descriptions: 
 

Section Subsection Manual  
Page 

Settings Overview Settings  31 
 Driver 34 
 Device Assignment 44 
 Firmware Download 50 
Configuration Overview Configuration 56 
 General 60 
 General Settings 61 
 Signal Configuration 67 

 Behavior 73 
 Messages 80 
Description Overview Description 81 
 XML DDF Viewer 82 
Diagnosis Overview Diagnosis 88 
 General Diagnosis  89 
 Firmware Diagnosis 91 
Extended Diagnosis Overview Extended Diagnosis 92 
Tools Overview Tools  100 
 Packet Monitor 101 
 IO Monitor 104 

Table 1: Descriptions Dialog Panes 

 
 

1.1.2 Online Help 
The EtherCAT Slave DTM contains an integrated online help. 

 To open the online help, click on Help or press F1. 
. 
 
 

1.1.3 List of Revisions 
Index Date Version Chapter Revision 
6 20-01-28 1.1100 5.5      Section Signal Configuration added.  

Table 2: List of Revisions 
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1.1.4 Conventions in this Manual 

Notes, operation instructions and results of operation steps are marked as 
follows: 

Notes 
 
 

 

Important: <important note you must follow to avoid malfunction> 

 

 

Note:  <general note> 

 

 

<note, where to find further information> 

 

Operation Instructions 
 

1. <instruction> 

2. <instruction> 
 

or 
 

 <instruction> 

 

Results 
 

 <result> 
 
 

Positions in Figures 

The Positions , ,  ... or , ,  ... or , ,  ...  refer to the 
figure used in that section. If the numbers reference to a section outside the 
current section then a cross reference to that section and figure is 
indicated. 
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1.2 Legal Notes 

Copyright 
© Hilscher Gesellschaft für Systemautomation mbH 

All rights reserved. 

The images, photographs and texts in the accompanying materials (in the 
form of a user's manual, operator's manual, Statement of Work document 
and all other document types, support texts, documentation, etc.) are 
protected by German and international copyright and by international trade 
and protective provisions. Without the prior written consent, you do not 
have permission to duplicate them either in full or in part using technical or 
mechanical methods (print, photocopy or any other method), to edit them 
using electronic systems or to transfer them. You are not permitted to make 
changes to copyright notices, markings, trademarks or ownership 
declarations. Illustrations are provided without taking the patent situation 
into account. Any company names and product designations provided in 
this document may be brands or trademarks by the corresponding owner 
and may be protected under trademark, brand or patent law. Any form of 
further use shall require the express consent from the relevant owner of the 
rights. 

Important notes 
Utmost care was/is given in the preparation of the documentation at hand 
consisting of a user's manual, operating manual and any other document 
type and accompanying texts. However, errors cannot be ruled out. 
Therefore, we cannot assume any guarantee or legal responsibility for 
erroneous information or liability of any kind. You are hereby made aware 
that descriptions found in the user's manual, the accompanying texts and 
the documentation neither represent a guarantee nor any indication on 
proper use as stipulated in the agreement or a promised attribute. It cannot 
be ruled out that the user's manual, the accompanying texts and the 
documentation do not completely match the described attributes, standards 
or any other data for the delivered product. A warranty or guarantee with 
respect to the correctness or accuracy of the information is not assumed. 

We reserve the right to modify our products and the specifications for such 
as well as the corresponding documentation in the form of a user's manual, 
operating manual and/or any other document types and accompanying 
texts at any time and without notice without being required to notify of said 
modification. Changes shall be taken into account in future manuals and do 
not represent an obligation of any kind, in particular there shall be no right 
to have delivered documents revised. The manual delivered with the 
product shall apply. 

Under no circumstances shall Hilscher Gesellschaft für Systemautomation 
mbH be liable for direct, indirect, ancillary or subsequent damage, or for 
any loss of income, which may arise after use of the information contained 
herein. 

Liability disclaimer 
The hardware and/or software was created and tested by Hilscher 
Gesellschaft für Systemautomation mbH with utmost care and is made 
available as is. No warranty can be assumed for the performance or 
flawlessness of the hardware and/or software under all application 
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conditions and scenarios and the work results achieved by the user when 
using the hardware and/or software. Liability for any damage that may have 
occurred as a result of using the hardware and/or software or the 
corresponding documents shall be limited to an event involving willful intent 
or a grossly negligent violation of a fundamental contractual obligation. 
However, the right to assert damages due to a violation of a fundamental 
contractual obligation shall be limited to contract-typical foreseeable 
damage. 

It is hereby expressly agreed upon in particular that any use or utilization of 
the hardware and/or software in connection with 

• Flight control systems in aviation and aerospace; 

• Nuclear fusion processes in nuclear power plants; 

• Medical devices used for life support and 

• Vehicle control systems used in passenger transport 

shall be excluded. Use of the hardware and/or software in any of the 
following areas is strictly prohibited: 

• For military purposes or in weaponry; 

• For designing, engineering, maintaining or operating nuclear systems; 

• In flight safety systems, aviation and flight telecommunications systems; 

• In life-support systems; 

• In systems in which any malfunction in the hardware and/or software 
may result in physical injuries or fatalities. 

You are hereby made aware that the hardware and/or software was not 
created for use in hazardous environments, which require fail-safe control 
mechanisms. Use of the hardware and/or software in this kind of 
environment shall be at your own risk; any liability for damage or loss due 
to impermissible use shall be excluded. 

Warranty 
Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that 
the software shall run without errors in accordance with the requirements 
listed in the specifications and that there were no defects on the date of 
acceptance. The warranty period shall be 12 months commencing as of the 
date of acceptance or purchase (with express declaration or implied, by 
customer's conclusive behavior, e.g. putting into operation permanently). 

The warranty obligation for equipment (hardware) we produce is 36 
months, calculated as of the date of delivery ex works. The aforementioned 
provisions shall not apply if longer warranty periods are mandatory by law 
pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a 
(1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all 
due care taken, the delivered product should have a defect, which already 
existed at the time of the transfer of risk, it shall be at our discretion to 
either repair the product or to deliver a replacement product, subject to 
timely notification of defect. 

The warranty obligation shall not apply if the notification of defect is not 
asserted promptly, if the purchaser or third party has tampered with the 
products, if the defect is the result of natural wear, was caused by 
unfavorable operating conditions or is due to violations against our 
operating regulations or against rules of good electrical engineering 
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practice, or if our request to return the defective object is not promptly 
complied with. 

Costs of support, maintenance, customization and product care 
Please be advised that any subsequent improvement shall only be free of 
charge if a defect is found. Any form of technical support, maintenance and 
customization is not a warranty service, but instead shall be charged extra. 

Additional guarantees 
Although the hardware and software was developed and tested in-depth 
with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall 
not assume any guarantee for the suitability thereof for any purpose that 
was not confirmed in writing. No guarantee can be granted whereby the 
hardware and software satisfies your requirements, or the use of the 
hardware and/or software is uninterruptable or the hardware and/or 
software is fault-free. 

It cannot be guaranteed that patents and/or ownership privileges have not 
been infringed upon or violated or that the products are free from third-party 
influence. No additional guarantees or promises shall be made as to 
whether the product is market current, free from deficiency in title, or can be 
integrated or is usable for specific purposes, unless such guarantees or 
promises are required under existing law and cannot be restricted. 

Confidentiality 
The customer hereby expressly acknowledges that this document contains 
trade secrets, information protected by copyright and other patent and 
ownership privileges as well as any related rights of Hilscher Gesellschaft 
für Systemautomation mbH. The customer agrees to treat as confidential all 
of the information made available to customer by Hilscher Gesellschaft für 
Systemautomation mbH and rights, which were disclosed by Hilscher 
Gesellschaft für Systemautomation mbH and that were made accessible as 
well as the terms and conditions of this agreement itself. 

The parties hereby agree to one another that the information that each 
party receives from the other party respectively is and shall remain the 
intellectual property of said other party, unless provided for otherwise in a 
contractual agreement. 

The customer must not allow any third party to become knowledgeable of 
this expertise and shall only provide knowledge thereof to authorized users 
as appropriate and necessary. Companies associated with the customer 
shall not be deemed third parties. The customer must obligate authorized 
users to confidentiality. The customer should only use the confidential 
information in connection with the performances specified in this 
agreement. 

The customer must not use this confidential information to his own 
advantage or for his own purposes or rather to the advantage or for the 
purpose of a third party, nor must it be used for commercial purposes and 
this confidential information must only be used to the extent provided for in 
this agreement or otherwise to the extent as expressly authorized by the 
disclosing party in written form. The customer has the right, subject to the 
obligation to confidentiality, to disclose the terms and conditions of this 
agreement directly to his legal and financial consultants as would be 
required for the customer's normal business operation. 
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Export provisions 
The delivered product (including technical data) is subject to the legal 
export and/or import laws as well as any associated regulations of various 
countries, especially such laws applicable in Germany and in the United 
States. The products / hardware / software must not be exported into such 
countries for which export is prohibited under US American export control 
laws and its supplementary provisions. You hereby agree to strictly follow 
the regulations and to yourself be responsible for observing them. You are 
hereby made aware that you may be required to obtain governmental 
approval to export, reexport or import the product. 
 

 

1.3 Registered Trademarks 
Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1 
and Windows® 10 are registered trademarks of Microsoft Corporation. 

EtherCAT® is a registered trademark of Beckhoff Automation GmbH, Verl, 
Germany, formerly Elektro Beckhoff GmbH. 

CODESYS® is a registered trademark of 3S-Smart Software Solutions 
GmbH, Deutschland. 

All other mentioned trademarks are property of their respective legal 
owners. 
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1.4 About EtherCAT Slave DTM 
You can use the EtherCAT Slave DTM to configure EtherCAT Slave 
devices within a FDT Framework and to view the device diagnosis. 

In a network project the EtherCAT Slave DTM can be dropped: 

• to the root line (Stand-Alone Slave), 

• or to the Master busline of a EtherCAT Master DTM. 

 

Slave DTM at the Root-Line (Stand-Alone Slave) 
Insert the EtherCAT Slave DTM to the root busline if you intend to configure 
only one single EtherCAT Slave device. 

Slave DTM at the Master Busline 
Insert the EtherCAT Slave DTM to the Master busline of the EtherCAT 
Master DTM if within the network project the Slave device and the Master 
device are used, i. e. if you intend to configure the Slave device and the 
Master device. 
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1.4.1 Requirements 
System Requirements 

• PC with 1 GHz processor or higher 

• Windows® XP SP3,  
Windows® Vista (32-Bit) SP2,   
Windows® 7 (32-Bit and 64-Bit) SP1,   
Windows® 8 (32-Bit and 64-Bit),  
Windows® 8.1 (32-Bit and 64-Bit),   
Windows® 10 (32-Bit and 64-Bit) 

• Administrator privilege required for installation 

• Internet Explorer 5.5 or higher 

• RAM: min. 512 MByte, recommended 1024 MByte 

• Graphic resolution: min. 1024 x 768 pixel 

• Keyboard and Mouse 

• Restriction: Touch screen is not supported. 
 

 

Note: If the project file is used on a further PC,  

 this PC must also comply with the above system requirements, 

 the device description files of the devices used in the project must be 
imported into the configuration software SYCON.net on the new PC, 

 and the DTMs of the devices used in the project must also be installed 
on that further PC. 

 
 
 

Requirements EtherCAT Slave DTM 
To configure the EtherCAT Slave device with the EtherCAT Slave DTM the 
following requirements have to be accomplished: 

• Completed hardware installation of a netX based DTM-compatible 
EtherCAT Slave device, inclusive loaded firmware and loaded 
configuration file 

• Installed FDT/DTM V 1.2 compliant frame application 

• Installed EtherCAT Master DTM (If Slave DTM is dropped to the Master 
busline.) 

• Loaded DTM in the Device Catalog of the FTD Framework 
 

 
Note: If the EtherCAT Slave DTM and the EtherCAT Slave device are 
installed on the same PC, the cifX Device Driver must be installed on 
that PC, as you can connect the DTM to the device.  

 

 

For more information to the hardware installation, please refer to the 
corresponding User Manual of your device.  
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1.5 Dialog Structure of the EtherCAT Slave DTM 
The graphical user interface of the DTM is composed of different areas and 
elements listed hereafter: 

1. A header area containing the General Device Information, 

2. The Navigation Area (area on the left side), 

3. The Dialog Pane (main area on the right side), 

4. OK, Cancel, Apply, Help, 

5. The Status Line containing information e. g. the online-state of the 
DTM. 

 

 
Figure 1: Dialog Structure of the EtherCAT Slave DTM 

 
 

 

 



Introduction 16/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

1.5.1 General Device Information 
 

Parameter Meaning 
IO Device Name of the device 

Vendor Vendor name of the device 

Device ID Identification number of the device 

Vendor ID Identification number of the vendor 

Table 3: General Device Information 

 
 

1.5.2 Navigation Area 
The Navigation Area contains folders and subfolders to open the dialog 
panes of the DTM. 
 

 
Figure 2: Navigation Area 

 

 Select the required folder and subfolder. 

 The corresponding Dialog pane is displayed.  

Hide / display Navigation 
 

 Hiding the navigation area (above right side). 

 
Opening the navigation area (below left side). 
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1.5.3 Dialog Panes 
At the dialog pane the Settings, Configuration, Diagnosis/Extended 
Diagnosis or the Tools panes are opened via the corresponding folder in 
the navigation area. 
 

Settings 
   Driver To establish a connection from the EtherCAT Slave DTM to the EtherCAT Slave 

device, on the pane Driver you can verify if the default driver is checked and 
respectively check another driver or multiple drivers. For further information, refer to 
section Driver on page 34. 

    Device Assignment On the pane Device Assignment you select the device and assign the device to the 
driver. For further information, refer to section Device Assignment on page 44. 

   Firmware Download The dialog on the pane Firmware Download is used to load a new firmware into the 
device. A detailed description can be found in section Firmware Download on page 50. 

Configuration 
   Configuration At the Configuration pane you can perform the basic configuration tasks for the 

EtherCAT Slave device. 
   General At the General pane EtherCAT Slave information is displayed. For further information, 

refer to section General on page 60. 
   General Settings The General Settings pane displays the most important general settings. For further 

information, refer to section General Settings on page 61. 

   Signal Configuration In the Signal Configuration pane the data structure of the input and output data for the 
signal assignment is determined. For further information, refer to section Signal 
Configuration on page 67. 

   Behavior At the Behavior pane the parameters of the Device checkup, the Process Data and the 
Watchdog are described. For further information, refer to section Behavior on page 73. 

   Mailbox At the Mailbox pane you can get information on mailbox-based data transfer and the 
CoE (CANopen over Ethernet) functionality. For further information, refer to section 
Mailbox on page 80. 

Diagnosis 

   Diagnosis/ 
   Extended Diagnosis 

At the Diagnosis panes information can be read for troubleshooting. For further 
information, refer to section Overview Diagnosis on page 88 and section Overview 
Extended Diagnosis on page 92. 

Tools 

   Packet Monitor/ 
   IO Monitor 

Under Tools the Packet Monitor and the IO Monitor are provided for test and 
diagnosis purposes. For further information, refer to section Packet Monitor on page 
101 or section IO Monitor on page 104. 

Table 4: Overview Dialog Panes 

 

 
Note: Accessing the Diagnosis panes of the EtherCAT Slave DTM 
requires an online connection from the EtherCAT Slave DTM to the 
EtherCAT Slave DTM.  

 

For further information, refer to section Connecting/Disconnecting Device 
on page 84. 
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1.5.4 OK, Cancel, Apply and Help 
OK, Cancel, Apply and Help you can use as described hereafter. 
 

 Meaning 
OK To confirm your latest settings, click OK. All changed values will be applied on the frame application 

database.  
The dialog then closes. 

Cancel To cancel your latest changes, click Cancel.  
Answer to the safety query Configuration data has been changed. Do you want to save the data? 
by Yes, No or Cancel. 
Yes: The changes are saved or the changed values are applied on the frame application database.  
The dialog then closes. 
No: The changes are not saved or the changed values are not applied on the frame application 
database.  
The dialog then closes. 
Cancel: Back to the DTM. 

Apply To confirm your latest settings, click Apply. All changed values will be applied on the frame application 
database.  
The dialog remains opened. 

Help To open the DTM online help, click Help.  

Table 5: OK, Cancel, Apply and Help 

 

1.5.5 Table Lines 
In the DTM dialog pane table lines can be selected, inserted or deleted. 
 

 Meaning 

 
To select the first line of a table use First Line. 

 
To select the previous line of a table use Previous Line. 

 
To select the next line of a table use Next Line. 

 
To select the last line of a table use Last Line. 

 
Create a new Line inserts new lines into the table. 

 
Delete selected Line deletes the selected line from the table.  

Table 6: Selecting, inserting, deleting Table Line 
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1.5.6 Status Bar 
The Status Bar displays information about the current state of the DTM. 
The current activity, e.g. download, is signaled graphically via icons in the 
status bar. 

 
Figure 3: Status Bar – Status Fields 1 to 6 

 

Status 
Field 

Icon / Meaning 

1 DTM Connection States 
 

 
Connected: Icon closed = Device is online 

 
 

Disconnected: Icon opened = Device is offline 

2 Data Source States 
 

 
Data set: The displayed data are read out from the instance data set 
(database). 

 
 

Device: The displayed data are read out from the device. 

3 States of the instance Date Set 
 

 
Valid Modified: Parameter is changed (not equal to data source). 

4 Changes directly made on the Device 
 

 
Load/configure diagnosis parameters: Diagnosis is activated. 

6 Device Diagnosis Status 

 
 

Save operation succeeded: The save operation has been successful. 

Further messages due to successful handling of device data. 
   Firmware Download: Firmware Download is running 

 
 

Save operation failed: The save operation has failed. 

Further fail operation messages due to incorrect communication due to 
malfunction in the field device or its peripherals. 

Table 7: Status Bar Icons [1] 

 

Offline State 
 

 
Save operation 
succeeded  

 
Firmware Download 

 
 

Firmware Download 
successful  

 
Online State and 
Diagnosis  

Figure 4: Status Bar Display Examples 
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2 Safety 
 

2.1 General Note 
The documentation in the form of a user manual, an operating instruction 
manual or other manual types, as well as the accompanying texts have 
been created for the use of the products by educated personnel. When 
using the products, all Safety Messages, Integrated Safety Messages, 
Property Damage Messages and all valid legal regulations must be obeyed. 
Technical knowledge is presumed. The user has to assure that all legal 
regulations are obeyed. 
 

2.2 Intended Use 
The EtherCAT Master DTM serves for configuration and diagnosis of 
EtherCAT Master devices.  
 

2.3 Personnel Qualification 
Personnel responsible for the application of the network system shall be 
aware of the system behavior and shall be trained in using the system. 
 
 

 

2.4 Safety Instructions 
To ensure your own personal safety and to avoid personal injury, you 
necessarily must read, understand, and comply with the safety instructions 
and safety messages in this manual before you install and operate your 
system. 

For cases if both, personal injury as well as property damage (damage of 
equipment or device) may occur together, you find the safety instructions in 
this section. 
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2.4.1 Communication Stop during Firmware or Configuration 
Download 

If you want to perform either a firmware update (as a download) or a 
configuration download, both via the EtherCAT Slave DTM, be aware of the 
following: 

• Together with the firmware download, an automated reset to the device 
is performed that will interrupt all network communication and all 
established connections will drop. 

• If you download the configuration during bus operation, the 
communication between master and slaves is stopped. 

Possible faulty System Operation 

• An unpredictable and unexpected behavior of machines and plant 
components may cause personal injury and property damage. 

 Stop the application program, before starting the firmware update or 
before downloading the configuration. 

 Make sure that your equipment operates under conditions that prevent 
personal injury or property damage. All network devices should be 
placed in a fail-safe mode, before starting the firmware update or before 
downloading a configuration. 

Loss of Device Parameters, Overwriting of Firmware 

• Both the firmware download and the configuration download erase the 
configuration data base. The firmware download overwrites the existing 
firmware in the network device. 

 To complete the firmware update and to make the device operable 
again, re-load the configuration after the firmware update has been 
finished. 

• Device parameters that have been saved volatile, e. g. as the 
temporarily set IP address parameters, are getting lost during the reset. 

 In order to prevent loss of configuration data, make sure that your 
project configuration data are saved non-volatile, before you initiate a 
firmware update or download the configuration. 

 

2.4.2 Mismatching System Configuration 
Mismatching system configuration loaded into the device could result in 
faulty data mapping in the application program and thus unexpected 
equipment operation may cause personal injury or damage of equipment. 

 In the device use only a configuration suitable for the system. 
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2.5 Property Damage 
To avoid property damage and damage to your system or to your 
equipment, you necessarily must read, understand, and comply with the 
safety instructions and safety messages in this manual before you 
configure your system. 
 
 

2.5.1 Power Disconnect while dowloading Firmware or Configuration  
 

If during the process of downloading a firmware or configuration 

• the power supply to a PC with the software application is interrupted, 

• or the power supply to the EtherCAT Slave device is interrupted, 

• or a reset to the device is performed, 

this may lead to the following consequences: 

Loss of Device Parameters, Firmware Corruption 

• The firmware download or the configuration download will be interrupted 
and remains incomplete. 

• The firmware or the configuration database will be corrupted and device 
parameters will be lost. 

• Device damage may occur as the device cannot be rebooted. 

Whether these consequences occur depends on when the power 
disconnect occurs during the download. 
 

Power Drop during Write and Delete Accesses in the File System 
The FAT file system in the netX firmware is subject to certain limitations in 
its operation. Write and delete accesses in the file system (firmware 
update, configuration download etc.) can destroy the FAT (File Allocation 
Table) if the accesses cannot be completed if the power drops. Without a 
proper FAT, a firmware may not be found and cannot be started. 

Make sure that the power supply to the device is not interrupted during 
write and delete accesses in the file system (firmware update, configuration 
download, etc.). 
 
 

2.5.2 Invalid Firmware 
Loading invalid firmware files could render your device unusable.  

 Only download firmware files to the device that are valid for this device. 

Otherwise you might be forced to return your device for repair. 
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2.6 Labeling of Safety Messages 
• The Section Safety Messages at the beginning of a chapter are 

pinpointed particularly and highlighted by a signal word according to the 
degree of endangerment. The type of danger is specified by the safety 
message text  

• The Integrated Safety Messages within an instruction description are 
highlighted with a signal word according to the degree of endangerment. 
The kind of danger is specified exactly by the safety message text.  

 

Signal Word Meaning (International) Meaning (USA) 

 Indicates a direct hazard with high risk, which 
will have a consequence of death or grievous 
bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, will result in death or serious injury. 

 Indicates a possible hazard with medium risk, 
which will have a consequence of death or 
(grievous) bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, could result in death or serious injury. 

 Indicates a minor hazard with medium risk, 
which could have a consequence of minor or 
moderate bodily harm if it is not avoided. 

Indicates a hazardous situation which if not 
avoided, may result in minor or moderate injury. 

 Indicates a property damage message. Indicates a property damage message. 

Table 8: Signal Words 

 

Note: The ANSI Z535.6 standard specifies in section 4.8: "Messages 
about hazards that could result in both, physical injury and property 
damage are considered safety messages, not property damage 
messages." Thus depending of the type of danger and its consequences, 
warning messages marked by a signal word DANGER, WARNING or 
CAUTION may include both, messages on physical injury and property 
damage. 

 

In this document all Safety Instructions and Safety Messages are designed 
according both to the international used safety conventions as well as to 
the ANSI Z535.6 standard, refer to safety reference [S1]. 
 

In this document the signal words ‘WARNING’, ‘CAUTION’ and ‘NOTICE’ are used 
according to ANSI Z535.6 standard. The meaning given in ISO/IEC 26514 [S4] section 
‘11.11 Contents of warnings and cautions’ is not relevant in this manual. 

2.7 References Safety 
 

[S1] ANSI Z535.6-2011 American National Standard for Product Safety Information in 
Product Manuals, Instructions, and Other Collateral Materials 

 
 

[S4] 26514-2010  -  IEEE Standard for Adoption of ISO/IEC 26514:2008 Systems and 
Software Engineering--Requirements for Designers and Developers of User 
Documentation 
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3 Getting started 
 

3.1 Configuration Steps 
The following overview provides to you the step sequence on how to 
configure a netX based EtherCAT Slave device with EtherCAT Slave DTM 
as it is typical for many cases. At this time it is presupposed that the 
hardware installation was done. 

The overview lists all the steps in a compressed form. For detailed 
descriptions of each step refer to the sections noted in the column For 
detailed information see section. 

The following two cases are considered: 

• Slave DTM at the Root-Line (Stand-Alone Slave)  

• and Slave DTM at the Master busline.  
 

3.1.1 Slave DTM at the Root-Line (Stand-Alone Slave) 
 

# Step Short Description For detailed 
information see section 

Page 

1 Load device 
catalog 

Depending of the FDT Container: 
For netDevice: 
- select Network > Device Catalog, 
- select Reload Catalog. 

 
(See Operating 
Instruction Manual 
netDevice and 
netProject) 

- 

2 Create new 
project / Open 
existing project 

Depending of the frame application. 
For the configuration software: 
- select File > New or File > Open. 

(See Operating 
Instruction Manual of the 
Frame Application) 

- 

3 Insert Slave into 
configuration 

Depending of the FDT Container: 
For netDevice: 
- in the Device Catalog under Gateway / Stand-
Alone Slave click to the Slave, 
- and insert the Slave via drag and drop  
to the root line in the network view. 

 
(See Operating 
Instruction Manual 
netDevice and 
netProject) 

- 

4 Open the Slave 
DTM configu-
ration dialog  

Open the Slave DTM configuration dialog. 
- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is displayed. 

- - 
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# Step Short Description For detailed 
information see section 

Page 

5 Verify or adapt 
Driver Settings 

In the Slave DTM configuration dialog: 
- select Settings > Driver. 

 
• Note! For PC cards cifX the cifX 

Device Driver is preset as a default 
driver. For all the other Hilscher devices 
the netX Driver is preset as a default 
driver.Use the cifX Device Driver if the 
EtherCAT Slave DTM is installed on the 
same PC as the EtherCAT Slave 
device. 

• Use the netX Driver to establish a 
USB, Serial (RS232) or TCP/IP 
connection from the EtherCAT Slave 
DTM to the EtherCAT Slave device. 

• The 3SGateway Driver for netX (V3.x) 
is used only in relationship with 
CODESYS. 

To search for devices you can check one 
or multiple drivers simultaneously. 

- Verify that the default driver is checked. 
- If necessary, check another driver or multiple 
drivers. 

Settings for Driver and 
Device Assignment 
and 
Driver  

32 
 
 
34 

6 Configure Driver If you use the netX Driver, you respectively must 
configure it. 
For netX Driver and communication via TCP/IP 
set the IP address of the device: 
- Select Settings > Driver > netX Driver > TCP 
Connection. 
- Via  add an IP range. 
- Under IP Address enter the IP Address of the 
device or an IP range. 
- Click Save. 
Adjust the driver parameters netX Driver 
USB/RS232 only if they differ from the default 
settings. 

 

Note!  
• The cifX Device Driver requires no 

configuration. 
• The configuration of the 3SGateway 

Driver for netX (V3.x) is carried out via 
the CODESYS surface. 

 

 
Configuring netX Driver 
 
 

 
37 
 

7 Assign Slave 
device (with or 
without 
firmware) 

Assign the device to this driver. 
In the Slave DTM configuration dialog: 
- select Settings > Device Assignment, 
- select a Slave device (with or without firmware), 
- therefore check the appropriate checkbox, 
- select Apply. 

Selecting the Device 
(with or without firmware) 

47 

8 Select and 
download 
firmware 

If not yet a firmware was loaded to the device: 
- Adhere to the necessary safety precautions to 
prevent personnel injury and property damage. 
In the Slave DTM configuration dialog: 
- select Settings > Firmware Download, 
- select Browse.., 
- select a firmware file, 
- select Open, 
- select Download and Yes. 

Safety Messages on 
Firmware or 
Configuration Download 
 
Firmware Download 

30 
 
 
 
50 
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# Step Short Description For detailed 
information see section 

Page 

9 Assign Slave 
device once 
more (with 
firmware and 
system chanal) 
For repeated 
download this 
step is omitted. 

In the Slave DTM configuration dialog: 
- select Settings > Device Assignment, 
- select Scan, 
- select the Slave device (with loaded firmware and 
defined system channel), 
- therefore check the appropriate checkbox, 
- select Apply, 
- close the Slave DTM configuration dialog via OK. 

Selecting the Device 
once more (with 
Firmware) 

48 

10 Configure Slave 
device 

Configure the Slave device. 
- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is displayed. 
In the Slave DTM configuration dialog: 
- select Configuration >General Settings, 
- set the Device Settings,  
- select Configuration > Signal Configuration, 
- proceed the signal configuration. 
- Close the Slave DTM configuration dialog via OK. 

Configuring Slave 
Parameter 
 
 
General Settings 
 
Signal Configuration  

58 
 
 
 
61 
 
67    

11 Save project Depending of the frame application. 
For the configuration software: 
- select File > Save. 

 
(See Operating 
Instruction Manual of the 
Frame Application) 

- 

12 Connect Slave 
device 

Depending of the FDT Container. 
For netDevice: 
- right click to the device icon of the Slave, 
- select Connect. 

Connecting/Disconnecting 
Device 

84 

13 Download 
Configuration 

- Adhere to the necessary safety precautions to 
prevent personnel injury and property damage. 
Depending of the FDT Container. 
For netDevice:  
- right click to the device icon of the Slave, 
- select Download. 

Safety Messages on 
Firmware or 
Configuration Download 
 
Download Configuration  

30 
 
 
 
86   

14 Diagnosis Depending of the FDT Container. 
For netDevice: 
- right click to the device icon of the Slave, 
- select Diagnosis. 
- The Slave DTM diagnosis dialog is displayed. 
(1) Check whether the communication is OK: 
Diagnosis > General Diagnosis > Device status 
"Communication" must be green! 
(2) „Communication“ is green: Open thel IO 
Monitor and test the input or output data. 
(3) „Communication“ is not green: Use Diagnosis 
and Extended diagnosis for troubleshooting. 
- close the Slave DTM diagnosis dialog via OK. 

Overview Diagnosis 88 

15 IO Monitor Depending of the FDT Container: 
For netDevice: 
- right click to the device icon of the Slave, 
- select Diagnosis,  
- select Tools > IO Monitor.  
- Check the input or output data, 
- close the IO Monitor dialog via OK. 

IO Monitor 104 

16 Disconnect Depending of the FDT Container. 
For netDevice:  
- right click to the device icon of the Slave, 
- select Disconnect. 

Connecting/Disconnectin
g Device 

84 

Table 9: Getting Started - Configuration Steps  (Slave DTM at the Root-Line (Stand-Alone 
Slave)) 
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3.1.2 Slave DTM at the Master Busline 
 

# Step Short Description For detailed information 
see section 

Page 

1 Load device 
catalog 

Depending of the FDT Container: 
For netDevice: 
- select Network > Device Catalog, 
- select Reload Catalog. 

 
(See Operating Instruction 
Manual netDevice and 
netProject) 

- 

2 Create new 
project / Open 
existing project 

Depending of the frame application. 
For the configuration software: 
- select File > New or File > Open. 

(See Operating Instruction 
Manual of the Frame 
Application) 

- 

3 Insert Master or 
Slave into 
configuration 

For netDevice: 
- in the Device Catalog click to the Master, 
- and insert the device via drag and drop  
to the root line in the network view, 
- in the Device Catalog click to the Slave, 
- and insert the device via drag and drop  
to the Master bus line in the network view. 

 
(See Operating Instruction 
Manual netDevice and 
netProject) 

- 

4 Open the Slave 
DTM configu-
ration dialog  

Open the Slave DTM configuration dialog. 
- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is displayed. 

- - 

5 Verify or adapt 
Driver Settings 

In the Slave DTM configuration dialog: 
- select Settings > Driver. 

 

Note! For PC cards cifX the cifX Device 
Driver is preset as a default driver. For all 
the other Hilscher devices the netX 
Driver is preset as a default driver. 

• Use the cifX Device Driver if the 
EtherCAT Slave DTM is installed on 
the same PC as the EtherCAT Slave 
device. 

• Use the netX Driver to establish a 
USB, Serial (RS232) or TCP/IP 
connection from the EtherCAT Slave 
DTM to the EtherCAT Slave device. 

• The 3SGateway Driver for netX 
(V3.x) is used only in relationship with 
CODESYS. 

To search for devices you can check one 
or multiple drivers simultaneously. 

 

- Verify that the default driver is checked. 
- If necessary, check another driver or multiple 
drivers. 

Settings for Driver and 
Device Assignment 
and 
Driver  

32 
 
 
34 

6. Configure Driver If you use the netX Driver, you respectively must 
configure it. 
For netX Driver and communication via TCP/IP 
set the IP address of the device: 
- Select Settings > Driver > netX Driver > TCP 
Connection. 
- Via  add an IP range. 
- Under IP Address enter the IP Address of the 
device or an IP range. 
- Click Save. 

 
Configuring netX Driver 
 
 

 
37 
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# Step Short Description For detailed information 
see section 

Page 

6 Configure Driver 
(continued) 

Adjust the driver parameters netX Driver 
USB/RS232 only if they differ from the default 
settings. 

 

Note!  
• The cifX Device Driver requires no 

configuration. 
• The configuration of the 3SGateway 

Driver for netX (V3.x) is carried out via 
the CODESYS surface. 

 

 
Configuring netX Driver 
 
 

 
37 
 

7 Assign Slave 
device (with or 
without 
firmware) 

Assign the device to this driver. 
In the Slave DTM configuration dialog: 
- select Settings > Device Assignment, 
- select a Slave device (with or without firmware), 
- therefore check the appropriate checkbox, 
- select Apply. 

Selecting the Device (with 
or without firmware) 

47 

8 Select and 
download 
firmware 

If not yet a firmware was loaded to the device: 
- Adhere to the necessary safety precautions to 
prevent personnel injury and property damage. 
In the Slave DTM configuration dialog: 
- select Settings > Firmware Download, 
- select Browse.., 
- select a firmware file, 
- select Open, 
- select Download and Yes. 

Safety Messages on 
Firmware or Configuration 
Download 
 
Firmware Download 

30 
 
 
 
50 
 

9 Assign Slave 
device once 
more (with 
firmware and 
system chanal) 
For repeated 
download this 
step is omitted. 

In the Slave DTM configuration dialog: 
- select Settings > Device Assignment, 
- select Scan, 
- select the Slave device (with loaded firmware and 
defined system channel), 
- therefore check the appropriate checkbox, 
- select Apply, 
- close the Slave DTM configuration dialog via OK. 

Selecting the Device once 
more (with Firmware) 

48 

10 Configure Slave 
device 

Configure the Slave device. 
- Double click to the device icon of the Slave. 
- The Slave DTM configuration dialog is displayed. 
In the Slave DTM configuration dialog: 
- select Configuration >General Settings, 
- set the Device Settings,  
- select Configuration > Signal Configuration, 
- proceed the signal configuration, 
- select Configuration >Behavior, 
- set the Behavior, 
- select Configuration >Mailbox->CoE, 
- set the CoE Settings. 
- close the Slave DTM configuration dialog via OK. 

Configuring Slave 
Parameter 
 
 
General Settings 
 
Signal Configuration  
 
Behavior 
 
CoE 

58 
 
 
 
61 
 
67 
 
73 
 
80 

11 Configure 
Master device  

Configure the Master device via the EtherCAT 
Master DTM netX. 

(See Operating Instruction 
Manual DTM for 
EtherCAT Master 
devices) 

- 

12 Save project Depending of the frame application. 
For the configuration software: 
- select File > Save. 

 
(See Operating Instruction 
Manual of the Frame 
Application) 

- 

13 Connect Slave 
device 

Depending of the FDT Container. 
For netDevice: 
- right click to the device icon of the Slave, 
- select Connect. 

Connecting/Disconnecting 
Device 

84 
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# Step Short Description For detailed information 
see section 

Page 

14 Download 
Configuration 

- Adhere to the necessary safety precautions to 
prevent personnel injury and property damage. 
Depending of the FDT Container. 
For netDevice:  
- right click to the device icon of the Slave, 
- select Download. 

Safety Messages on 
Firmware or Configuration 
Download 
 
Download Configuration  

30 
 
 
 
86   

15 Diagnosis Depending of the FDT Container. 
For netDevice: 
- right click to the device icon of the Slave, 
- select Diagnosis. 
- The Slave DTM diagnosis dialog is displayed. 
(1) Check whether the communication is OK: 
Diagnosis > General Diagnosis > Device status 
"Communication" must be green! 
(2) „Communication“ is green: Open thel IO 
Monitor and test the input or output data. 
(3) „Communication“ is not green: Use Diagnosis 
and Extended diagnosis for troubleshooting. 
- close the Slave DTM diagnosis dialog via OK. 

Overview Diagnosis 88 

16 IO Monitor Depending of the FDT Container: 
For netDevice: 
- right click to the device icon of the Slave, 
- select Diagnosis,  
- select Tools > IO Monitor.  
- Check the input or output data, 
- close the IO Monitor dialog via OK. 

IO Monitor 104 

17 Disconnect Depending of the FDT Container. 
For netDevice:  
- right click to the device icon of the Slave, 
- select Disconnect. 

Connecting/Disconnecting 
Device 

84 

Table 10: Getting Started - Configuration Steps (Slave DTM at the Master busline) 
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3.2 Safety Messages on Firmware or Configuration Download 
If you perform a firmware download or a configuration download via the 
EtherCAT Slave DTM be aware of the following: 
 

  
Communication Stop caused by Firmware or Configuration Download 
Initiating a firmware or configuration dowload process during bus operation 
will stop the communication and a subsequent plant stop may cause 
unpredictable and unexpected behavior of machines and plant 
components, possibly resulting in personal injury and damage to your 
equipment. 
The firmware download overwrites the existing firmware. The 
communication stop may cause loss of device parameters and possible 
device damage may occur. 
 Stop the application program, before you start the firmware or 

configuration dowload. 

 Make sure that all network devices are placed in a fail-safe condition. 
 
 

  
Mismatching System Configuration 
Mismatching system configuration loaded into the device could result in 
faulty data mapping in the application program and thus unexpected 
equipment operation may cause personal injury or damage of equipment. 
 In the device use only a configuration suitable for the system. 
 
 

 

 

 
Power Disconnect while downloading Firmware or Configuration 
If the power supply to the PC or device is interrupted while the firmware or 
configuration is being downloaded, the download will be aborted, the 
firmware or the configuration database will be corrupted, the device 
parameters will be lost, and the device may be damaged. 
 During firmware or configuration download process do not interrupt the 

power supply to the PC, or to the device and do not perform a reset to 
the device! 

 
 
 

 

 

 
Invalid Firmware 
Loading invalid firmware files could render your device unusable. 
 Only proceed with a firmware version valid for your device. 
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4 Settings 
4.1 Overview Settings 

Settings Dialog Panes 
The table below gives an overview for the individual Settings dialog panes 
descriptions: 
 

EtherCAT Slave DTM Folder Name / 
Section 

Subsection Manual 
Page 

 
Navigation Area – 
Settings (Example) 
Additional drivers can be 
displayed. 

Driver  34 

 Verify or adapt Driver Settings 34 

 cifX Device Driver 36 

 netX Driver 36 
  Configuring netX Driver 37 

Device Assignment  44 

 Scanning for Devices 44 

  Scanning for all Devices or for suitable only 46 

 Selecting the Device (with or without firmware) 47 

 Selecting the Device once more (with Firmware) 48 
Firmware Download  50 

Table 11: Descriptions of the Dialog Panes Settings 

 
 

 
Note: To edit the Settings dialog panes you need User Rights for 
“Maintenance”. 

 
 

 

Notice the descriptions in the section Settings for Driver and Device 
Assignment on page 32. 

 

To access to the online help with the descriptions of the drivers: 

 Select Settings > Driver > [Name of the assigned driver]. 

 Press the F1 key. 
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4.2 Settings for Driver and Device Assignment 
 

The following steps are needed to establish a connection from the 
EtherCAT Slave DTM to the EtherCAT Slave device: 

Verifying or adapting Driver Settings 
Verify the Driver Settings and adapt them if necessary. 
 

1. Open the DTM configuration dialog. 

 In the FDT container netDevice double click to the EtherCAT Slave 
device icon. 

2. Verify that the default driver is checked and respectively check another 
or multiple drivers. 

 

 Select Settings > Driver. 
 

 
Note! For PC cards cifX the cifX Device Driver is preset as a default 
driver. For all the other Hilscher devices the netX Driver is preset as a 
default driver. 
 Use the cifX Device Driver if the EtherCAT Slave DTM is installed on 

the same PC as the EtherCAT Slave device. 
 Use the netX Driver to establish an USB, Serial (RS232) or TCP/IP 

connection from the EtherCAT Slave DTM to the EtherCAT Slave 
device. 
 The 3SGateway Driver for netX (V3.x) is used only in relationship with 

CODESYS. 
 To search for devices on the network you can check one or multiple 

drivers simultaneously. 
 

 Verify that the default driver for your device is checked. 

 If necessary, check another driver or multiple drivers. 

Configuring Driver 
 

 
Note! 
 The cifX Device Driver requires no configuration. 
 The configuration of the 3SGateway Driver for netX (V3.x) is carried 

out via the CODESYS surface. 
 

If you use the netX Driver, you respectively must configure it. 

3. Configure the netX Driver if necessary. 

For the driver netXDriver an individual driver dialog window can be opened 
where you can configure the driver. 

 Select Settings > Driver > netX Driver. 
 For netX Driver and communication via TCP/IP set the IP address of 

the device. 

Adjust the driver parameters netX Driver USB/RS232 only if they differ 
from the default settings. 
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Assigning the Slave device to the DTM 
4. Scan for and select the devices (with or without firmware). 

 Select Settings > Device Assignment. 
 Under Device selection select suitable only or all and then Scan. 

 In the table check the required devices. 

 Select Apply. 

Selecting and downloading the Firmware 
5. If not yet a firmware was loaded to the device, select and download the 

firmware. 

 Select Settings > Firmware Download. 

 Select and download the firmware via Download. 

 Select Apply. 

6. Scan for and select the devices (with firmware and defined system 
channel) once more. 

For repeated download this step is omitted. 

 Select Settings > Device Assignment. 
 Select Scan. 

 In the table check the required device. 

7. Close the DTM configuration dialog via OK. 

Connecting the Device 
8. In netDevice put a right-click on the EtherCAT Slave device icon. 

9. Select the Connect command from the context menu. 

 In the network view the device description at the device icon of the 
Slave is displayed with a green colored background. The EtherCAT 
Slave device now is connected to the EtherCAT Slave DTM via an 
online connection. 

Further Information 

 

For descriptions about these steps refer to the sections following here-
after.  
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4.3 Driver 
The Driver dialog pane displays the drivers to be used for a EtherCAT 
Slave DTM to establish a device communication connection.  
 

 
Note! A default driver is set in the configuration software.  

 

 
Figure 5: Default Driver ‚cifX Device Driver’ for PC cards cifX  

Parameter Meaning 
Driver Name of the driver (for more details see descriptions hereafter) 

Version  ODMV3 Version of the respective driver 

ID ID of the driver (driver identification) 

Table 12: Driver Selection List Parameters 

To establish a connection from the EtherCAT Slave DTM to the EtherCAT 
Slave device, verify if the default driver is checked and respectively check 
another driver or multiple drivers. 
 
 

4.3.1 Verify or adapt Driver Settings 
Proceed as follows: 

1. Select Settings > Driver in the navigation area. 

 The Driver dialog pane is displayed with the available drivers and the 
setting for the default driver.  

 
Figure 6: Default Driver ‚cifX Device Driver’ for PC cards cifX (example) 

 
Figure 7: Default Driver ‚netX Driver’ for Hilscher devices except for PC cards cifX (example) 

2. Verify that the default driver is checked. 
 

 Verify that the default driver for your device is checked. 
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Default Driver (Pre-settings in the Configuration Software): For PC cards 
cifX the cifX Device Driver is preset as a default driver. For all the other 
Hilscher devices the netX Driver is preset as a default driver. 
 

3. Respectively check another driver. 
 

 
Note! The driver used for the connection from the EtherCAT Slave DTM 
to the EtherCAT Slave device must be supported by the device and must 
be available for the device. 

 

• Use the cifX Device Driver if the EtherCAT Slave DTM is installed on 
the same PC as the EtherCAT Slave device. 

• Use the netX Driver to establish a USB, Serial (RS232) or TCP/IP 
connection from the EtherCAT Slave DTM to the EtherCAT Slave 
device. 

• The 3SGateway Driver for netX (V3.x) is used only in relationship with 
CODESYS. The version V3.x refers to the driver version defined by 3S-
Smart Software Solutions GmbH. 

 Check the checkbox for the driver in the selection list. 
 

4. Respectively check multiple drivers. 

To search for devices on the network you can check multiple drivers 
simultaneously. 

 
Figure 8: Manual Selection of multiple drivers (Example) 
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4.3.2 cifX Device Driver 
In the EtherCAT Slave-DTM for the cifX Device Driver no driver dialog 
pane is available, since for the cifX Device Driver no driver settings are 
required. 

The cifX Device Driver will be used if the EtherCAT Slave DTM is installed 
in the same PC as the EtherCAT Slave device.  
 

 
Note: To establish a connection from a DTM to a Slave device via the 
cifX Device Driver, the cifX Device Driver must be installed and the 
driver must have access to the Slave device. 

 

 

 

4.3.3 netX Driver 
The netX Driver is used to connect the DTM to the device via different 
connection types. The DTM communicates with the device via an USB 
connection, a serial (RS232) connection or a TCP/IP connection. The netX 
Driver establishes 

• via the USB interface of the device and the USB port of the PC an USB 
connection to the device, 

• via the RS232 interface of the device and the COM port of the PC a 
serial connection (RS232) to the device 

• and via Ethernet a TCP/IP connection to the device. 
 

To connect the DTM to the physical layer of the device the netX Driver 
software works in combination with the software components: 

• “USB/COM connector” for the USB connection and for the serial 
connection (RS232) and  

• “TCP/IP connector” for the Ethernet connection. 
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4.3.4 Configuring netX Driver 
The following steps are required to configure the netX Driver: 

USB/RS232 Connection 
To set the driver parameters for an USB/RS232 connection note: 
 

 
Note: Adjust the driver parameters netX Driver USB/RS232 only if they 
differ from the default settings. After saving the changed driver 
parameters, these parameters are used for the device assignment when 
scanning devices. 

 

For setting the driver parameters for an USB connection or a serial 
connection: 

1. Select Settings > Driver > netX Driver > USB/RS232 Connection. 

 Set the driver netX Driver USB/RS232 parameters. 
 

TCP/IP Connection 
For setting the driver parameters for a TCP/IP connection: 

1. Select Settings > Driver > netX Driver > TCP Connection. 

2. Set IP Address of the device: 

 Add an IP Range via Select IP Range . 

3. Under IP Range Configuration > IP Address enter the IP Address of 
the device (Use IP Range is unchecked). 

Or 

4. Set IP Range: 

 Check Use IP Range. 

 Under IP Range Configuration > IP Address enter the start address 
(left side) and the ending address of the IP scanning range (right side). 

5. Click Save, to save the IP address or the IP range. 

 After saving the changed driver parameters, these parameters are used 
for the device assignment when scanning devices. 
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4.3.5 netX Driver - USB/RS232 Connection 
The communication from the DTM to the device via an USB/RS232 
Connection is used when the DTM is installed on a PC and between the 
PC and the device 

• an USB connection 

• or a serial connection (RS232) exists. 
 

The DTM accesses the device via the USB interface or via the RS232 
interface. This requires either to connect an USB port of the PC to the USB 
interface of the device using an USB cable or to connect a physical COM 
port of the PC to the RS232 interface of the device via a serial cable. 

The netX Driver / USB/RS232 Connection supports all physical and 
virtual COM ports available on the PC. 

Via the RS232 interface or USB interface, the device is configured or 
diagnosis is performed. 
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4.3.5.1 Driver Parameters for netX Driver - USB/RS232 Connection 

The settings of the driver parameters for the USB/RS232 connection are 
made via the netX Driver / USB/RS232 Connection configuration dialog. 

 Open the USB/RS232 Connection dialog via navigation area Settings 
> Driver > netX Driver.  

 The USB/RS232 Connection dialog is displayed: 

 
Figure 9: netX Driver > USB/RS232 Connection  

 

Parameter Meaning Range of Value / 
Default Value 

Enable USB/RS232 
Connector (Restart of 
ODM required) 

checked: The netX Driver can communicate via the 
USB/RS232 interface. 
unchecked: The netX Driver can not communicate via the 
USB/RS232 interface. 
If the check mark for Enable USB/RS232 Connector is set 
or removed, then the ODM server must be restarted1, to 
make the new setting valid. 
_______ 
1 Restart the ODM server via the ODMV3 Tray Application: 

-In the foot line click on  using the right mouse key.  

- In the context menu select Service > Start. 

checked,  
unchecked; 
Default: 
unchecked  

Select Port Depending on the COM ports (interfaces) available on the 
PC, they will be listed under Select Port. 

COM 1 to COM N 

Port Configuration 
Disable Port checked: No connection. 

unchecked: The netX Driver tries to establish a connection 
using the configured USB/RS232 interface. 

checked,  
unchecked (Default) 

Baud rate Transfer rate: number of bits per second. 
The device must support the baud rate. 

9.6, 19.2, 38.4, 57.6 or 
115.2 [kBit/s]; 
Default (RS232): 115.2 
[kBit/s] 



Settings 40/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

Parameter Meaning Range of Value / 
Default Value 

Stop bits Number of stop bits sent after the transfer of the send data 
for synchronization purposes to the receiver. 

Stop bit: 1, 1.5, 2; 
Default (RS232): 1 

Send Timeout Maximum time before the transfer of the transmission data is 
canceled, when the send process fails, for example, because 
of the transfer buffer is full.  

100 … 60.000 [ms]; 
Default (RS232 and 
USB): 1000 ms 

Reset Timeout Maximum time for a device reset, including the re-
initialization of the physical interface used for the 
communication. 

100 … 60.000 [ms]; 
Default (RS232 and 
USB): 5000 ms 

Byte size Number of bits per byte by byte specification 7 Bit, 8 Bit; 
Default (RS232): 8 Bit 

Parity In the error detection in data transmission using parity bits, 
"parity" describes the number of bits occupied with 1 in the 
transmitted information word. 
No Parity: no parity bit 
Odd Parity: The parity is "odd" if the number of bits occupied 
with 1 in the transmitted information word will be odd. 
Even parity: The parity is "even" if the number of bits 
occupied with 1 in the transmitted information word will be 
even. 
Mark Parity: if the parity bit is always 1, this will be named 
mark-parity (the bit does not contain any information). 
Space Parity: if the parity bit always 0, this will be named 
space-parity (the bit represents an empty space). 

No Parity,  
Odd Parity, 
Even Parity, 
Mark Parity, 
Space Parity; 
Default (RS232):  
No Parity 

Keep Alive Timeout The "Keep Alive" mechanism is used to monitor whether the 
connection to the device is active. Connection errors are 
detected using a periodic heartbeat mechanism. The 
heartbeat mechanism will be initiated after the set time has 
elapsed if the communication has failed. 

100 … 60.000 [ms]; 
Default (RS232 and 
USB): 2000 ms 

Restore Resets all settings in the configuration dialog to the default 
values. 

 

Save Saving all settings made in the configuration dialog netX 
Driver > Save USB/RS232 Connection, i. e. only for the 
selected connection type. 

 

Save All Saving all settings made in the configuration dialog netX 
Driver, i. e. for all connection types. 

 

Table 13: Parameters netX Driver > USB/RS232 Connection 

 
 



Settings 41/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

4.3.6 netX Driver - TCP/IP Connection 
The communication from the DTM to the device via a TCP/IP Connection 
is used in the following two typical applications: 

Application 1: The device has its own Ethernet interface. The DTM is 
installed on a PC and the TCP/IP connection is established from this PC to 
the stand-alone device. The IP address of the device is used. 

Application 2: The device is installed in a remote PC. The DTM is installed 
on an additional PC and the TCP/IP connection is established from this PC 
to the remote PC. The IP address of the remote PC is used. For the TCP/IP 
connection is made, on the remote PC the cifX TCP/IP server must be 
started. The cifX TCP/IP server allows the remote access to the device via 
a TCP/IP connection. 
 

 
Note: An exe file for the cifXTCP/IP server is provided on the product CD 
in the Tools directory. 

 

Via the TCP/IP interface of the device or of the remote PC, the device is 
configured or diagnosis is performed. 
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4.3.6.1 Driver Parameters for netX Driver - TCP/IP Connection 

The settings of the driver parameters for the TCP/IP connection are made 
via the netX Driver / TCP Connection configuration dialog. 

 Open the TCP Connection dialog via navigation area Settings > 
Driver > netX Driver.  

 The dialog netX Driver is displayed: 

 Select TCP Connection. 

 
Figure 10: netX Driver > TCP Connection  

 
 
 
 
 

Parameter Meaning Range of Value / 
Default Value 

Enable TCP Connector 
(Restart of ODM 
required) 

checked: The netX Driver can communicate via the TCP/IP 
interface. 
unchecked: The netX Driver can not communicate via the 
TCP/IP interface. 
If the check mark for Enable TCP Connector is set or 
removed, then the ODM server must be restarted1, to make 
the new setting valid. 
_______ 
1 Restart the ODM server via the ODMV3 Tray Application: 

-In the foot line click on  using the right mouse key.  

- In the context menu select Service > Start. 

checked,  
unchecked; 
Default: 
unchecked 

Select IP Range Via Select IP Range already created IP ranges can be 
selected. 

Via  an additional IP range can be added. 

Via  an IP range can be deleted. 
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Parameter Meaning Range of Value / 
Default Value 

Scan Timeout [ms] With Scan Timeout can be set, how long to wait for a 
response while a connection is established. 

10 … 10000 [ms]; 
Default: 100 ms 

IP Range Configuration 
Disable IP Range checked: No connection. 

unchecked: The netX Driver tries to establish a connection 
using the configured TCP/IP interface. 

checked,  
unchecked (Default) 

IP Address (left) Enter the IP address of the device, (if Use IP Range is not 
checked). 
Enter the start address of the IP scanning range, (if Use IP 
Range is checked). 

valid IP address; 
Default: 192.168.1.1 

Use IP Range checked: An IP address range is used. 
unchecked: Only one IP address is used. 

checked,  
unchecked; 
Default: 
unchecked 

IP Address (right) Enter the ending address of the IP scanning range, (only if 
Use IP Range is checked). 

valid IP address; 
Default: 0.0.0.0 

Address Count Displays the scanning range address count, depending on 
the selected IP-start or IP-end address. (For this read the 
note given below.) 

recommended: 10  

TCP Port Identifies the endpoint of a logical connection or addresses a 
specific endpoint on the device or PC. 

0 - 65535; 
Default Hilscher device: 
50111 

Send Timeout [ms] Maximum time before the transfer of the transmission data is 
canceled, when the send process fails, for example, because 
of the transfer buffer is full.  

100 … 60.000 [ms]; 
Default (TCP/IP): 1000 
ms 

Reset Timeout [ms] Maximum time for a device reset, including the re-
initialization of the physical interface used for the 
communication. 

100 … 60.000 [ms]; 
Default (TCP/IP): 2000 
ms 

Keep Alive Timeout 
[ms] 

The "Keep Alive" mechanism is used to monitor whether the 
connection to the device is active. Connection errors are 
detected using a periodic heartbeat mechanism. The 
heartbeat mechanism will be initiated after the set time has 
elapsed if the communication has failed. 

100 … 60.000 [ms]; 
Default (TCP/IP): 2000 
ms 

Restore Resets all settings in the configuration dialog to the default 
values. 

 

Save Saving all settings made in the configuration dialog netX 
Driver > Save TCP/IP Connection, i. e. only for the selected 
connection type. 

 

Save All Saving all settings made in the configuration dialog netX 
Driver, i. e. for all connection types. 

 

Table 14: Parameters netX Driver > TCP Connection 

 

 

Note: Do not use large IP ranges in combination with a low scan timeout. Microsoft 
introduced in Windows® XP SP2 a limit of concurrent half-open outbound 
TCP/IPconnections (connection attempts) to slow the spread of virus and malware from 
system to system. This limit makes it impossible to have more than 10 concurrent half-
open outbound connections. Every further connection attempt is put in a queue and 
forced to wait. Due to this limitation a large IP range used in combination with a low scan 
timeout could prevent the connection establishment to a device. 

 

 



Settings 44/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

4.4 Device Assignment 
 

 
Note: In the Device Assignment dialog pane you first must assign the 
EtherCAT Slave device to the EtherCAT Slave DTM by checking the 
check box. This is essential to establish an online connection from the 
EtherCAT Slave DTM to the EtherCAT Slave device later, as described in 
section Connecting/Disconnecting Device on page 84. 

 

Therefore in the Device Assignment dialog pane you scan for the 
EtherCAT Slave device and select it.  

If the device did not get a firmware or shall get a new firmware: 

1. first you scan for the device (with or without firmware) and select the 
device,  

2. then you download a firmware to the device and 

3. subsequently you scan for the device (with firmware) once more and 
select the device again. 

 

 

4.4.1 Scanning for Devices 
 

1. Select Settings > Device Assignment in the navigation area. 

 The dialog pane Device Assignment is displayed. 

 
Figure 11: Device Assignment - detected Devices (* The name of the device class is 
displayed.) – Example for a device without firmware 

2. Under Device Selection select suitable only. 

3. Select Scan, to start the scanning process. 

 In the table all devices are displayed, which can be connected to the 
EtherCAT Slave DTM via the preselected driver. 

 

 
Note: For devices, which have been found via the cifX Device Driver in 
the column Access path the indication …\cifX[0toN]_SYS is displayed. 
This is correct, as long as a device did not get a firmware. After the 
firmware download has been completed, in the column Access path the 
indication …\cifX[0toN]_Ch[0to3] is displayed. 
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Parameter Meaning Range of Value / 
Default Value 

Device selection Selecting suitable only or all devices. suitable only, all 

Device Device class of the EtherCAT Slave devices.  

Hardware Port 
0/1/2/3 

Shows, which hardware is assigned to which communication interface.  

Slot number Shows the Slot Number (Card ID) preset at the PC card cifX via the Rotary 
Switch Slot Number (Card ID). 
The indication n/a means that no Slot-Nummer (Card ID) exists. This will 
occur if the PC card cifX is not equipped with a Rotary Switch Slot Number 
(Card ID) or for PC cards cifX equipped with a Rotary Switch Slot Number 
(Card ID) if the rotary switch is set to the value 0 (zero). 

1 to 9, 
n/a 
 

Serial number Serial number of the device  

Driver Name of the driver  

Channel Protocol Shows, which firmware is loaded to which device channel. 
The data for the used channel consists of the protocol class and the 
communication class. 
a.) For devices without firmware: Undefined Undefined, 
b.) For devices with firmware: Protocol name corresponding to the used 
Firmware 

 

Access path 
(last column on 
the right) 

Depending on the used driver in the column Access path different data to 
the device are displayed. 
For the cifX Device Driver the following data are displayed:  
a.) For devices without firmware: …\cifX[0toN]_SYS, 
b.) For devices with firmware: …\cifX[0toN]_Ch[0to3]. 
cifX[0toN] = Board number 0 to N 
Ch[0to3] = Channel number 0 to 3 

Depending on the 
device and on the 
driver:  
board or channel 
number, IP address 
or COM interface 

Access path  
(at the lower side 
of the dialog 
pane) 

If in the table a device is checked, under Access path (at the lower side of 
the dialog pane) the driver identification or depending on the used driver 
additional data to the device will be displayed. 
For the cifX Device Driver the following data are displayed:  
a.) For devices without firmware: …\cifX[0toN]_SYS, 
b.) For devices with firmware: …\cifX[0toN]_Ch[0to3]. 
cifX[0toN] = Board number 0 to N 
Ch[0to3] = Channel number 0 to 3 

driver identification 
(ID) 
depending on the 
device and on the 
driver:  
board or channel 
number, IP address 
or COM interface 

Table 15: Parameters of the Device Assignment 
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4.4.1.1 Scanning for all Devices or for suitable only 

all 
1. Under Device Selection select all. 

2. Select Scan. 

 
Figure 12: Device Assignment - detected Devices (* The name of the device class is 
displayed.) Example for Devices without Firmware 

 In the table all devices are displayed, which are attainable in the 
network and which can be connected to a single DTM each via the 
preselected drivers. 

 

 
Note: During a subsequent firmware download in the selection window 
Select Firmware File all files from the selected folder are displayed, 
under Files of Type „All Files (*.*)“ is displayed and the check box 
Validate the selected firmware file. is unchecked. 

 
 

suitable only 
1. Under Device Selection select suitable only. 

2. Select Scan. 

 In the table all devices are displayed, which can be connected to the 
EtherCAT Slave DTM via the preselected drivers. 

 

 
Note: During a subsequent firmware download in the selection window 
Select Firmware File only firmware files from the selected folder are 
displayed, under Files of Type „Firmware Files (*.nxm)“ or „Firmware 
Files (*.nxf)“ is displayed and the check box Validate the selected 
firmware file. is checked. 
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4.4.2 Selecting the Device (with or without firmware) 
 

 
Note: A connection with the EtherCAT Slave DTM can only be 
established with one EtherCAT Slave device. 

 

To select the physical EtherCAT Slave device (with or without firmware): 

1. Check the appropriate device. 

 
Figure 13: Device Assignment - Selecting the Device (* The name of the device class is 
displayed.) – Example for a device without firmware / one Device is selected  

 

 Under Access path (below in the dialog pane) the access path to the 
device, e. g. the driver identification, or depending on the used driver 
additional access data of the device are displayed. 

2. Select Apply, to apply the selection. 
 

 
Note: Before an online connection from the EtherCAT Slave DTM to the 
EtherCAT Slave device can be established, a firmware must be loaded to 
the device and the device must be selected once more. 

 
 

 

For further information refer to section to section Firmware Download on 
page 50 or to section Selecting the Device once more (with Firmware) on 
page 48. 
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4.4.3 Selecting the Device once more (with Firmware) 
 

 
Note: For repeated download this step is omitted. 

 

To select the EtherCAT Slave device (with firmware and defined system 
channel) once more, proceed as described hereafter: 

all 
1. Under Device Selection select all. 

2. Select Scan. 

 In the table all devices are displayed, which are attainable in the 
network and which can be connected to a DTM via the preselected 
drivers. 

3. Check the appropriate device. 

 
Figure 14: Device Assignment - Selecting the Device (* The name of the device class is 
displayed.) – Example for Devices with and without Firmware / one Device is selected 

 

 

Note: After the firmware download has been completed, for the devices which have been 
detected via the cifX Device Driver the following data are displayed:  
- In the column Channel Protocol: the data for the firmware for the used channel 
- In the column Access path or under Access path (below in the dialog pane):  
 the data: …\cifX[0toN]_Ch[0to3]. 
 cifX[0toN] = board number 0 to N  
 Ch[0to3] = channel number 0 to 3 

 

4. Select Apply, to apply the selection.  

5. Or select OK, to apply the selection and to close the DTM interface 
dialog.  

6. Connect the DTM to the device using the context menu (right mouse 
click). 
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Or: 

suitable only 
1. Under Device Selection select suitable only. 

2. Select Scan. 

 In the table all devices are displayed, which can be connected to the 
EtherCAT Slave DTM via the preselected drivers. 

3. Check the appropriate device. 

 
Figure 15: Device Assignment - Selecting the Device (* The name of the device class is 
displayed.) – Example for a device with firmware / one Device is selected 

 

 

Note: After the firmware download has been completed, for the devices which have been 
detected via the cifX Device Driver the following data are displayed:  
- In the column Channel Protocol: the data for the firmware for the used channel 
- In the column Access path or under Access path (below in the dialog pane):  
 the data: …\cifX[0toN]_Ch[0to3]. 
 cifX[0toN] = board number 0 to N  
 Ch[0to3] = channel number 0 to 3 

 

4. Select Apply, to apply the selection.  

5. Or select OK, to apply the selection and to close the DTM interface 
dialog.  

6. Connect the DTM to the device using the context menu (right mouse 
click). 

 

 

For further information how to establish an online connection from the 
EtherCAT Slave DTM to the EtherCAT Slave device, refer to section 
Connecting/Disconnecting Device on page 84. 
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4.5 Firmware Download 
Using the Firmware Download dialog a firmware can be transferred to the 
device. 

 
Note: Prior to the firmware download, you must select the driver and the 
Slave device (with or without firmware) and the device must be assigned 
to the hardware. For further information refer to section Overview Settings 
on page 31. 

To load the firmware to the device: 

1. In the navigation area select Settings > Firmware Download. 

 The dialog Firmware-Download pane is displayed. 

 
Figure 16: Firmware Download 

Element Meaning 
Name The path and name of the firmware file selected are displayed. 

Version The version and build version of the firmware file selected are displayed. 

Browse… Via ‘Browse…’ you can select the firmware file for the download.  

Download Via ‘Download’ you can download the firmware to the device. 

Table 16: Parameter Firmware Download 

 Select Browse. 

Device is not assigned to the Hardware 
If the device is not assigned to the Hardware, the error message ‘The 
device is not assigned to the hardware!’ is displayed: 

 
Figure 17: Error Message ‘The device is not assigned to the hardware!’ 
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 Click OK and select and assign the Slave device as described in 
section Device Assignment.  

Device is assigned to the Hardware 
 The selection window Select Firmware File is displayed. 

 Enlarge the selection window to view the columns Hardware and 
Version.  

 

 
Figure 18: Window ‘Select Firmware File’ (Example CIFX) 
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Parameter Meaning Range of Value / 
Default Value 

Column Name File name of the firmware file 
To sort the entries of the window Select Firmware File by name click to 
the column head . 

nxf, nxm 

Column 
Firmware 

Name of the firmware (consisting of the protocol name and protocol class)  

Column 
Hardware 

Device class of the associated hardware e. g. CIFX,  
COMX, COMX 51,  
NETJACK 10,  
NETJACK 50,  
NETJACK 51,  
NETJACK 100, 
NETTAP 50 (Gateway), 
NETTAP 100 (Gateway), 
NETBRICK 100 (Gateway) 

Column 
Version 

Firmware version x.x (build x) 

Tooltip  To view the tooltip information move with the mouse pointer over the 
selected firmware line. 

 

 

Files of Type „All Files (*.*)“ if before in the Device Assignment pane under Device 
selection all was selected.  
„ Firmware Files (*.nxm)“ or Firmware Files (*.nxf) if before in the Device 
Assignment pane under Device selection suitable only was selected. 

All Files (*.*), 
Firmware Files (*.nxm), 
Firmware Files (*.nxf) 

Recent folders Path of the recently opened folder  
Firmware As soon as the firmware file has been selected, under Firmware the 

name, the version and the build version as well as the device class for the 
selected firmware is displayed. 

Name, Version, Build 
Version, Device Class 
for the selected firmware 

Help Button, to open the online help of the DTM.  

Table 17: Parameters Select Firmware File 

 

Further descriptions to the selection window Select Firmware File are 
included in the context sensitive help (F1 key) of the Microsoft 
Corporation. 

 

 

Note: After in the Device Assignment pane under Device selection all or suitable only 
has been set, during a subsequent firmware download in the selection window Select 
Firmware File the following data are displayed or set: 

(for list box entry ) all suitable only 
In the selection window 
Select Firmware File: 

all files from the 
selected folder 

only firmware files from the 
selected folder 

Under Files of Type*: „All Files (*.*)“ „Firmware Files (*.nxm)“, 
„Firmware Files (*.nxf)“ 

Validation: A restricted validation 
will be performed if 
the selected firmware 
is applied for the 
download. 

A validation is made whether 
the firmware file is suitable for 
the EtherCAT Slave DTM. 

*These settings in the selection window Select Firmware File can also be changed 
manually. 

3. In the selection window mark the firmware file to be loaded using the 
mouse. 

 In the selection window under Firmware the name and the version of 
the firmware are displayed. 
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4. In the selection window select the Open button. 

Validation 
 A validation is made, whether the selected firmware file is suitable for 

the EtherCAT Slave device. 

Invalid Firmware 
 

  
Invalid Firmware 
Loading invalid firmware files could render your device unusable. 

  Only proceed with a firmware version valid for your device. 

 If a firmware file is selected, which is not valid for the assigned device, 
the request Select Firmware File will be displayed. 
‘Invalid firmware for assigned device!   
[detailed explication]  
Shall firmware file nevertheless be applied for the download?’ 

 
Figure 19: Request Select Firmware File - Example Invalid Firmware 

 Answer to the request with No and select a valid firmware. 

 The selection window is closed. 
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Valid Firmware 
 The selection window is directly closed (without dialog). 
 

5. Start firmware upgrade.   
 

  
Communication Stop caused by Firmware Update,  
faulty System Operation possible, Overwriting of Firmware or  
Loss of Device Parameters 
Before you initiate a firmware download process, while the bus is still in 
operation status: 
 Stop the application program. 

 Make sure that all network devices are placed in a fail-safe condition. 
 

  
Firmware Corruption or Loss of Parameters caused by Power 
Disconnect during Firmware Download 

  During firmware download process, do not interrupt the power supply to 
the PC, or to the device and do not perform a reset to the device! 

 In the dialog pane Firmware Download click to the Download button, 
to download the firmware. 

 The request Do you really want to download the firmware? is 
displayed. 

 
Figure 20: Request - Do you really want to download the firmware? 

6. Click Yes. 

 If you are sure, that you have selected the appropriate firmware file 
answer to the request with Yes otherwise with No.  

 During the download a progress bar is displayed (‘Download active, 
device performs initialization…’), in the status line a clock / green hook 
symbol is displayed and in the dialog pane Firmware Download 
Download is grayed out. 

 
Figure 21: Firmware Download - Progress Bar  
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Figure 22: Clock Symbol and Hook Symbol green 

 In the Firmware-Download dialog pane the path and name as well as 
the version of the selected firmware file are displayed. 

 
Figure 23: Firmware Download – Download 
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5 Configuration 
5.1 Overview Configuration 

5.1.1 General Remarks 
The appearance of the EtherCAT Slave DTM depends on the mode of 
invocation, i.e. whether the EtherCAT Slave DTM has been dragged to the 
root line (Stand-aloane Slave) or to a Master line (Slave connected to a 
Master). 
 

 

Take care of the descriptions in the section Configuration Steps on page 
24. 

 

 
Note: In order to transfer the configuration to the EtherCAT Slave device, 
download the data of the configuration parameters in the EtherCAT Slave 
device. See section Download Configuration on page 86. 

 

5.1.2 Slave DTM at the Root-Line (Stand-Alone Slave) 
In this case of the tree view looks like: 

 
Figure 24: Configuration (Slave DTM at the Root-Line (Stand-Alone Slave)) 

If the EtherCAT Slave DTM is dragged to the root busline within the 
network project, at Configuration the following panes will be available: 

Configuration > General Settings 

Dialog Panes “Configuration” 
The table below gives an overview about the available Configuration 
dialog panes descriptions: 
 

Folder Name / 
Section 

Subsection Page 

Configuration Signal Configuration 67 

General Settings 61 

Table 18: Dialog Panes Configuration 
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All other descriptions given in this chapter are not applicable if the 
EtherCAT Slave DTM has been dragged to the root busline in the network 
project. 
 

5.1.3 Slave DTM at the Master Busline 
In this case of the tree view looks like: 

 
Figure 25: Configuration > General (Slave DTM at the Master busline) 

If the EtherCAT Slave DTM is dragged to the Master busline of the 
EtherCAT Master DTM within the network project, at Configuration the 
following panes will be available: 

• General pane 

• General Settings pane 

• Behavior pane 

• Mailbox pane 

Dialog Panes “Configuration” 
The table below gives an overview about the available Configuration 
dialog panes descriptions: 
 
 

Folder Name / 
Section 

Subsection Page 

Configuration General 60 
General Settings 61 
Signal Configuration 67 

Behavior 73 
Mailbox 80 

Table 19: Dialog Panes Configuration 
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5.2 Configuring Slave Parameters 
The steps provided in the following two sections are alternatively required 
for the two cases listed hereafter, to configure the parameters of the 
EtherCAT Slave device using the EtherCAT Slave DTM: 

• Slave DTM at the Root-Line (Stand-Alone Slave)  

• and Slave DTM at the Master busline.  
 
 

5.2.1 Slave DTM at the Root-Line (Stand-Alone Slave) 
If in the network project the EtherCAT Slave DTM is dropped to the root 
busline: 

General Settings 
1. Set the Device Settings: 

 Select Configuration > General Settings in the navigation area. 

 Under Bus Startup: Select option Automatic or Application 
Controlled.  

 Under Watchdog time: Set Watchdog time. 

Signal Configuration 
2. Proceed the Signal Configuration: 

 Select Configuration > Signal Configuration in the navigation area. 

Close Slave DTM Configuration Dialog 
3. Click OK in order to close the Slave DTM configuration dialog and to 

store your configuration. 

Configuration Download to the EtherCAT Slave Device 
 Adhere to the necessary safety precautions to prevent personnel injury 

and property damage.  
 

 
Note: In order to transfer the configuration to the EtherCAT Slave device, 
download the data of the configuration parameters in the EtherCAT Slave 
device. See section Download Configuration on page 86. 

 
 

Further Information 
 

 

For more information refer to the section hereafter. 
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5.2.2 Slave DTM at the Master Busline 
If in the network project the EtherCAT Slave DTM is dropped to the root 
busline: 

General 
1. Put in an optional description of the device  

 Select Configuration > General. If you want, you can put in a 
descriptive text about the slave device under Description.  

General Settings 
2. Set the Device Settings: 

 Select Configuration > General Settings in the navigation area. 

 Under Bus Startup: Select option Automatic or Application 
Controlled.  

 Under Watchdog time: Set Watchdog time. 

Signal Configuration 
3. Proceed the Signal Configuration: 

 Select Configuration > Signal Configuration in the navigation area. 

Behavior 
4. Make the settings concerning the behavior of the device: 

 In the navigation area, select Configuration > Behavior and then 
make your settings. 

Mailbox >CoE 
5. Make settings for CoE (CANopen over EtherCAT): 

 In the navigation area, select Configuration > Mailbox >CoE and then 
make your CoE settings. 

Close Slave DTM Configuration Dialog 
6. Click OK in order to close the Slave DTM configuration dialog and to 

store your configuration. 

Configuration Download to the EtherCAT Slave Device 
 Adhere to the necessary safety precautions to prevent personnel injury 

and property damage.  
 

 
Note: In order to transfer the configuration to the EtherCAT Slave device, 
download the data of the configuration parameters in the EtherCAT Slave 
device. See section Download Configuration on page 86. 

 
 

Further Information 
 

 

For more information refer to the sections hereafter. 
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5.3 General 
 

The General pane shows the Description of the EtherCAT Slave. 

This pane is only available in case of a Slave DTM at the Master busline. 
 

 
Note: The Station Address is set by the EtherCAT Master, therefore the 
corresponding data field is not editable. 

 

 
Figure 26: Configuration > General 

 

Parameter Meaning Editable 
Description Symbolic Name of the EtherCAT Slave station Yes 
Device type Device type as defined in the DDF No 
Device name Device name as defined in the DDF No 
Product 
revision 

Product revision as defined in the DDF or E²PROM No 

Physics EtherCAT Port configuration: available ports and their types, see Table 21: 
Coding of Parameter "Physics" below. 

No 

Station 
Address 

Station Address denominates a logical address.  
The station address of a slave is set in the Master DTM. 

No 

Table 20: General Page Parameters 

 

Physics in the context of EtherCAT Port configuration is described by two 
characters indicating the physical interface of the connection. The coding is 
as follows: 
 

Physics Port type 
K E-Bus 
Y 100Base-TX 
F 100Base-FX  

Table 21: Coding of Parameter "Physics" 
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5.4 General Settings 
At the General Settings pane device related settings can be made. These 
settings are assigned with the download of the configuration. 
 

 

Information about the download you find in section Download 
Configuration on page 86. 

 

 
Figure 27: General Settings 

 

 
Note: The setting options at the dialog pane General Settings for client 
specific variants of the configuration software can differ from the setting 
options displayed here. 

 

 

 



Configuration  62/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

5.4.1 Interface Parameters 

5.4.1.1 Bus Startup 

This parameter offers the options Automatic an Application Controlled. 
 

If Automatic is selected, the EtherCAT Master device starts with the data 
exchange on the bus after the initializing has been ended.  

When Application Controlled is selected, the application program must 
activate the data exchange on the bus. 
 

 
Note: The setting options under Bus Startup for client specific variants of 
the configuration software can differ from the setting options displayed 
here. 

 

5.4.1.2 Watchdog Time for Application Monitoring 

 
Figure 28: Device Settings > Application Monitoring 

 

The Watchdog time determines the time within which the device watchdog 
must be re-triggered from the application program while the application 
program monitoring is activated. When the watchdog time value is equal to 
0 the watchdog is deactivated and the application program monitoring is 
deactivated too. 

The permissible range of values of the watchdog time is 20 to 65535. By 
default the watchdog time value equals to 1000 ms.  
 

Watchdog time Range of Value / Value 
Permissible range of values 20 … 65535 ms 
Default 1000 ms 
The software watchdog is deactivated. 0 (ms) 

Table 22: Range of Value / Value for the Watchdog time 

 

 
Note: The setting options under Watchdog Time for client specific 
variants of the configuration software can differ from the setting options 
displayed here. 

 

5.4.1.3 I/O Data Status 

This parameter allows setting  of the status of the input or the output data 
i.e. the I/O Status Enable bit (bit 1 of the system flags) and the I/O Status 
8/32Bit bit (bits 2 of the system flags).  

For each input and output date the following status information (in Byte) is 
memorized in the dual-port memory. 

Currently the field is grayed out as only the option ‘None’ is supported. 
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5.4.2 Ident Parameters 
The following table lists all ident parameters of the EtherCAT Stand-alone 
Slave DTM along with their meaning and their default values: 
 

Parameter Meaning Default value Subindex (within 
Object 0x1018) 

VendorID Vendor Identification 
number of the 
manufacturer of an 
EtherCAT device. 

0xE0000044 
(denoting device 
has been 
manufactured by 
Hilscher) 

1 

Product code Product code of the 
device 

1 2 

Revision Revision number of the 
device as specified by 
the manufacturer 

0x20001 3 

Serial number Serial number of the 
device 

0 4 

Table 23: Ident Parameters 

These parameters are exactly those which are also stored in EtherCATs 
object dictionary within the object with index 0x1018 thus the table also 
mentions the corresponding subindex numbers of each parameter. 

The values for the parameters VendorID, Product code and Revision can 
be taken from the XML file which is bundled with the particular firmware. 
The following default value sets for the identification data have been 
defined: 
Firmware Vendor Id Product Code Revision Number 

cifX 0xE0000044 0x00000001 0x00020001 

comX 0xE0000044 0x00000003 0x00020001 

netIC 0xE0000044 0x0000000B 0x00000000 

Table 24: Values for the Ident Parameters VendorId, ProductCode and RevisionNumber 

5.4.3 Data Parameters  
The following table shows the data parameters of the general Settings. 
 

Parameter Meaning Default value Maximum value 
Input Data 
Bytes 

Process Data Input Size 
Number of data bytes used 
for input 

200 Byte 256 Byte 

Output Data 
Bytes 

Process Data Output Size 
Number of data bytes used 
for output 

200 Byte 256 Byte 

Sync impulse 
length 

Sync impulse length  (in units 
of 10 ns) 

100 
(= 1000 ns) 

65535 
(=655350 ns) 

Table 25: Data Parameters 
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5.4.4 Messages 

5.4.4.1 Errors 

The following table provides an overview which error situations might occur 
in the “General Settings” pane. 

Problem The error message  

 
appears. 

Explanation This error message appears in case either a value below 20 but unequal 0 or a 
value exceeding 65535 is put in for the watchdog time in the configuration  pane. 

Action Put in a correct the value for the watchdog time (between 20 and 65535) or switch 
the watchdog feature off (in order to do so, set the value of the watchdog time 
equal to 0)! 

Problem The error message  

 
appears. 

Explanation No value at all has been put in for the watchdog time in the configuration pane. 

Action Put in a correct the value for the watchdog time (between 20 and 65535) or switch 
the watchdog feature off (in order to do so, set the value of the watchdog time 
equal to 0)! 

Problem The error message  

 
appears. 

Explanation The specified value for the length of either input or output data exceeds the upper 
limit of 256 bytes. 

Action Specify a lower value either for the input data length or for the output data length! 

Problem The error message  
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appears. 

Explanation The specified values of input data length and output data length may not be 0 at 
the same time. 

Action Specify at least one non-zero value either for input data length or output data 
length. 

Problem The error message  

 
appears. 

Explanation The sum of the specified values of input data length and output data length may 
exceed 512 bytes. 

Action Specify a lower value for at least one of these values so that the sum of both 
values does not exceed the 512 bytes limit. 

Problem The error message  

 
appears. 

Explanation In an input field requiring a hexadecimal value, you tried to put in a character 
which is neither a digit nor any of the letters (“A,B,C,D.E,F”), for instance another 
letter. 

Action Correct your input accordingly! 

Problem The error message  

 
appears. 

Explanation An input field (either the input data length or the output data length) is empty. 



Configuration  66/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

Action Check for the empty field. Then specify a valid value there. 

Problem The error message  

 
appears. 

Explanation The specified value for the Sync Impulse Length exceeds the upper limit of 65535 
bytes. 

Action Specify a lower value either for the Sync Impulse Length! 
Table 26:  Possible Error Messages issued at General Settings Pane 

5.4.4.2 Warnings 

The following table provides informs about which warnings might appear in 
the configuration pane. 

Problem The error message  

 
appears. 

Explanation You have changed the configuration data. 

Action If you want to store the configuration data permanently, click at Yes otherwise at 
No or return to preceding screen with Cancel. 

Table 27:  Possible Warning  Messages issued at General Settings Pane 
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5.5 Signal Configuration 
 

With the EtherCAT Slave, the process data to be transmitted via the bus is 
configured at fieldbus level as the number of output data bytes or input data 
bytes. 

The application requires the information on the meaning and data type of 
the input and output data specified via the signals. 
 

 
Important: First, configure in the General Settings dialog pane the 
number of output data bytes or input data bytes. Do not perform the signal 
configuration steps until you have finished. 

 

In the Signal Configuration dialog you can define the data structure of the 
input or output data of your device and define the I/O data for your 
application 

• assign data types, 

• assign names or signal names, and 

• define data structures. 

The aim is to create a suitable signal configuration, which subsequently 
enables easy identification of the transmitted input and output data. This 
requires a structuring of the input and output data according to signals and 
the configuration of signal names or data types suitable for the individual 
application cases.  

Signal names 
The names assigned by default by the configuration software for the signals 
distinguish between input and output signals. You can replace these 
general names with suitable designations, such as "Setpoint" or "Status".  

Merging or splitting signals 
You can merge or split signals or data types by configuring the data type 
and the number of signals.  

Example: 1 "Word (input)" = 16 "Bit (input)".  

This means that 1 "word input data" corresponds to 16 signals with the data 
type "Bit".  

To identify split data types, the configuration software assigns appropriate 
suffixes to the signal names, which depend on the selected new data type, 
for example _Byte_0, _Byte_4 ... or _Bit_1, _Bit_2 ... 
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5.5.1 Signal Configuration Pane 
 Select Configuration > Signal Configuration in the navigation area. 

 The dialog pane Signal Configuration is displayed.  

 
Figure 29: Signal Configuration Pane 

 
 

Parameter Description Range of Value/ Value 
Slot Process data object for the output or input data RxPdo 0x1600, 

TxPdo 0xA00 

Name Name for the Process Data Object including object number for the 
output or input data of the EtherCAT slave. 

Outputs0 <RxPdo 0x1600>, 
Inputs0 <TxPdo 0xA00> 

Module Type PDO type of the process data object RxPdo, TxPdo 

Signal level 
Name Name of the input or output signal that can be set here. 

The configuration software assigns the names by default: 
1 Byte Out (0) ... 1 Byte Out (199) 
1 Byte In (0) ... 1 Byte In (199) 

String 

Type Data type of the input or output signal (depending on the configured 
size of the I/O data). 

bit, byte, signed8, unsigned8, 
word, signed16/24, 
unsigned16/24, dword, 
signed32/40/48/56, 
unsigned32/40/48/56, lword, 
signed64, unsigned64,  
real32, real64 

Offset Offset of the input or output signal, in relation to the data in the 
process data object. 

 

Table 28: Explanations Signal Configuration Pane 
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5.5.2 Create Signal Configuration 
In the Signal Configuration pane, you can edit the signal configuration in 
the lower table. 

Edit Signal 
 Right-click on the signal to be configured to open the context menu. 

 
Figure 30: Edit Signal 

 Click Edit Signal.  
 The Edit Signal dialog pane is opened. 

 
Figure 31: Edit Signal Dialog Pane 

Parameter Description Range of Value/ 
Value 

Name Here you can edit the signal name. String 
Original Type Input or output signal data type preconfigured by the configuration software 

or by the user. 
 

New Type Here you can edit the new data type for the input or output signal.  
Only permitted data types are displayed in the selection list. 

bit, byte, signed8, 
unsigned8, word, 
signed16/24, 
unsigned16/24, 
dword, 
signed32/40/48/56, 
unsigned32/40/48/56, 
lword, signed64, 
unsigned64,  
real32, real64 

Count Here you can set the number of signals with the data type "New Type".  
Apply as Array If checked, the signal is displayed as an array. If unchecked, the individual 

signals are displayed. 
Checked, 
unchecked, 
Default: checked 

Table 29:  Explanations Edit Signal Dialog Pane 
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 In the field Name edit the signal name. 

 Use New Type to define the new data type or Count to define the 
number of signals. 

 
Figure 32: Edit Signal (Example) 

 Click OK.  

 When splitting signals, the configuration software assigns suitable 
standard suffixes to the signal name to identify the subordinate signals. 

 
Figure 33: Signal Output_Assembly split (Example) 

 You can further split already split signals. 

 Click Apply to save the created configuration. 
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Reset 

 
Note: As long as you have not applied the created signal configuration, 
you can undo the steps you have taken by clicking Reset. 

 Right-click on the configured signal to open the context menu. 

 
Figure 34: Reset 

 Click Reset. 
 The created signal configuration with a splitting of a signal is undone. 

Merge Signals 
 First, confirm a signal splitting with Apply. 

 Then press Shift and mark the signals to be merged with the mouse 
pointer. 

 Open the context menu by right-clicking on the marked signals. 

 
Figure 35: Merge Signals 

 Click Merge Signals. 

 The dialog pane Merge Signals opens. 
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Figure 36: Dialog Pane Merge Signals 

Parameter Description Range of Value/ 
Value 

Name Here you can edit the signal name. 
The name displayed here contains the suffix assigned by the configuration 
software, example „_Byte_0” or “_Byte_0_Bit_0“. 

String 

First in Group Shows the name of the first signal from which the merge will start.    
Last in Group Shows the name of the last signal up to which the merge is performed.    
New Type Here you can edit the new data type for the input or output signal.  

Only permitted data types are displayed in the selection list. 

bit, byte, signed8, 
unsigned8, word, 
signed16/24, 
unsigned16/24, 
dword, 
signed32/40/48/56, 
unsigned32/40/48/56, 
lword, signed64, 
unsigned64,  
real32, real64 

Count Shows the number of data types of the merged signal, which you can 
adjust here. 

 

Apply as Array An array is formed when merging. Allways checked 

Table 30:  Explanations Merge Signals Dialog Pane 

 For the signals that you want to merge, specify the name via Name, the 
data type via New Type or the number of data types of the merged 
signal via Count. 

 Click OK. 

 The signals are merged.  

 Click Apply to save the created configuration. 
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5.6 Behavior 
At the page Behavior, the parameters of  

• the state machine timeout values 

• the device checkup,  

• the process data  

• and the watchdog timer. 

are set and displayed. 

This pane is only available in case of a Slave DTM at the Master busline. 
 

 
Figure 37: Configuration > Behavior 
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5.6.1 State Machine Timeout 
For various transitions between states of the EtherCAT slave state machine 
the associated timeout values can be configured separately in the state 
machine timeout section of the ‘Behavior’ dialog: 

• I2P 

This value applies to the transition from Init state to Pre-Operational 
state 

• P2S, S2O  

This value applies to the transition from Pre-Operational state to 
Safe-Operational state and from Safe-Operational state to 
Operational state. 

• Back to P, I  

This value applies to the transition from any higher state back to Pre-
Operational state or Init state. 

• O2S  

This value applies to the transition from Operational state to Safe-
Operational state. 

 

 
Note: These timeout values are specified in units of milliseconds. 

 

 
Figure 38: Configuration > Behavior > State Machine Timeout - Configuration 

  



Configuration  75/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

5.6.2 Device Check-up 
The device check-up part of the Behavior dialog looks like: 

 
Figure 39: Configuration > Behavior > Device Check 

The following table shows which items identifying the EtherCAT device can 
optionally be verified during device check-up if marked in the dialog 
accordingly. 
 

Parameter Meaning 
VendorID Device’s vendor ID (DDF or stored device-internally) 
Product code Device’s product code (DDF or stored device-internally) 
Revision Device’s revision (DDF or stored device-internally) 

Table 31: Parameters Behavior > Device checkup 

A verification of the serial number is not available here. 

The values within the DDF file are verified against the corresponding 
information stored in the device (for example, within an E²PROM circuit), if 
the according check box is marked.  

5.6.3 Process Data 
EtherCAT supplies different command sets for reading and writing: 

• a combined read/write command (LRW) 

• separate read and write commands (LRD/LWR) 

This option allows to choose between these alternatives: 

 
Figure 40: Configuration > Behavior > Process data 

 

Parameter Meaning 
Use LRD/LWR 
instead of LRW 

Logical read and write operation: 
If marked, separate EtherCAT read (LRD) and write 
(LWR) commands will be used. 
Otherwise, a combined EtherCAT read and write 
(LRW) command will be used. 

Table 32: Parameters Behavior > Process data 

For more information on EtherCAT read and write commands see the 
EtherCAT Communication Specification, version 1.0, section 6.2 “EtherCAT 
Services”, page 43. 
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5.6.4 Watchdog 
Both the entire PDI (Process Data Interface) and all sync managers 
(separately) are monitored by watchdog timers.  

The following rules apply for resetting the watchdog timers: 

• Each access from the application controller to the EtherCAT Slave 
controller resets the watchdog timer of the Process Data Interface. 

• Each write access to the associated memory area of a sync manager 
resets the sync manager’s watchdog timer. 

The watchdog timeout values can be calculated using the formula given 
below from an individually configurable value and a common multiplier.  

The “Watchdog” part of the “Behavior” dialog allows specifying the 
multiplier and the individual values for PDI watchdog and sync manager 
watchdogs. 

 
Figure 41: Configuration > Behavior > Watchdog 

 

Parameter Meaning 

Set multiplier Watchdog multiplier, content of the register 0x400 
Set PDI watchdog PDI watchdog, see note below 
Set SM watchdog SM watchdog, see note below 

Include WC state 
Bit(s) 

If this check box is marked, an input variable is added to the slave 
device, that shows the working counter state of the EtherCAT slave 
device. 

Table 33: Parameters Configuration > Behavior > Watchdog 

 
Note: The PDI & SM watchdog timeout values are calculated as follows. 

PDI watchdog timeout =  

([value of register 0x400] + 2) * 40 * [value of register 0x 410] 

SM watchdog timeout =  

([value of register 0x 400] + 2) * 40 * [value of register 0x 420] 
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5.6.5 Messages 

5.6.5.1 Errors 

The following table provides an overview which error situations might occur 
in the “Behavior” pane. 

Problem The error message  

 
appears. 

Explanation The specified value for the State Machine Timeout (I->P) exceeds the upper limit 
of 65535 bytes. 

Action Specify a lower value than 65535 for the State Machine Timeout (I->P)! 

Problem The error message  

 
appears. 

Explanation The specified value for the State Machine Timeout (P->S,S->O) exceeds the 
upper limit of 65535 bytes. 

Action Specify a lower value than 65535 for the State Machine Timeout (P->S,S->O)! 

Problem The error message  

 
appears. 

Explanation The specified value for the State Machine Timeout (Back to P,I) exceeds the 
upper limit of 65535 bytes. 

Action Specify a lower value than 65535 for the State Machine Timeout (Back to P,I)! 

Problem The error message  
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appears. 

Explanation The specified value for the State Machine Timeout (O->S) exceeds the upper limit 
of 65535 bytes. 

Action Specify a lower value than 65535 for the State Machine Timeout (O->S)! 

Problem The error message  

 
appears. 

Explanation The specified value for the Multiplier (Register 0x400) exceeds the upper limit of 
65535 bytes. 

Action Specify a lower value than 65535 for the Multiplier (Register 0x400)! 

Problem The error message  

 
appears. 

Explanation The specified value for the PDI Watchdog (Register 0x410) exceeds the upper 
limit of 65535 bytes. 

Action Specify a lower value than 65535 for the PDI Watchdog (Register 0x410)! 

Problem The error message  

 
appears. 

Explanation The specified value for the SM Watchdog (Register 0x420) exceeds the upper 
limit of 65535 bytes. 



Configuration  79/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

Action Specify a lower value than 65535 for the SM Watchdog (Register 0x420)! 
Table 34: Possible Error Messages issued at Behavior Pane 

5.6.5.2 Warnings 

The following table provides informs about which warnings might appear in 
the configuration pane. 

Problem The error message  

 
appears. 

Explanation You have changed the configuration data. 

Action If you want to store the configuration data permanently, click at Yes otherwise at 
No or return to preceding screen with Cancel. 

Table 35:  Possible Warning  Messages issued at Behavior Pane 
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5.7 Mailbox 
This pane is only available in case of a Slave DTM at the Master busline. It 
has one option: CoE. 

5.7.1 CoE 
For slave devices supporting the CoE MailBox, the following dialog page is 
additionally displayed: 

 
Figure 42: Configuration > Mailbox > CoE Mailbox Settings 

The dialog page provides the following information: 

• The channel number of the sync manager (for mailbox input and output) 

• The configured mailbox size (this applies both for the input mailbox and 
for the output)mailbox  

The complete MailBox configuration for each slave with MailBox support is 
done in the EtherCAT Master-DTM. 
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6 Description 
6.1 Overview Description 

The Description pages contain the following information: 

• XML Viewer page: the devices XML file content in HTML style. 

Description Dialog Panes 
The table below informs about the contents of the Description dialog page: 
 

EtherCAT Slave-DTM Folder Name / Section Page 

 
Navigation Area – Description 

XML DDF Viewer 81 

Table 36: Descriptions of the Description Pages 
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6.2 XML DDF Viewer 
The XML DDF Viewer displays the content of the DDF file of the device 
which is stored in an XML format.. 
 

 
Figure 43: XML DDF Viewer 

 

Under Filename the absolute file directory path and the file name of the 
displayed DDF file is displayed. Find what offers a search feature to search 
for text contents within the text of the DDF file. 

In the DDF Viewer window on the left side, the line number is displayed for 
simple overview, the further entries show the DDF file in text format. 
 

Parameter Meaning 
FIlename File directory path and the file name of the displayed DDF file. 
Find what Search feature to search for text contents within the text of the 

DDF file. 
Match case Search option 
Match whole word Search option 

Table 37: Device Description – XML DDF Viewerr 
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The XML DDF Viewer page consists of the following elements: 

• File name shows the absolute path of the DDF file. 

• Find what offers searching for specific text within the DDF file. 

• Using the Find Next button allows you to jump to the next occurrence of 
the text to be searched for within the XML DDF file. 

• Check Match case if you want to perform a case-sensitive search. 

• Check Match whole word if only entire words should match and 
fragments of words should be excluded from matching. 

 

 
Note: You can also access the search functionality of the XML DDF 
Viewer by typing Ctrl-F on the keyboard. 
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7 Online Functions 
 

7.1 Connecting/Disconnecting Device 
 

 
Note: Several EtherCAT Slave DTM functions e. g. Diagnosis or the 
configuration download in the FDT Framework require an online 
connection from the EtherCAT Slave DTM to the EtherCAT Slave  device. 

Connecting Device 
The following steps are needed to establish a connection from the 
EtherCAT Slave DTM to a EtherCAT Slave device: 

Under Settings in the Driver pane: 

1. Verify that the default driver is checked and respectively check another 
or multiple drivers. 

2. Configure the driver if necessary. 

Under Settings in the Device Assignment pane: 

3. Scan for the devices (with or without firmware). 

4. Select the device (with or without firmware) and apply the selection. 
 

 

Before you download the firmware adhere to the necessary safety 
precautions to prevent personnel injury and property damage. For more 
refer to section Safety Messages on Firmware or Configuration Download 
on page 30. 

Under Settings in the Firmware Download pane if not yet a firmware was 
loaded to the device: 

5. Select and download the firmware. 

Under Settings in the Device Assignment pane if not yet a firmware was 
loaded to the device: 
 

6. Scan for the device (with firmware) once more. 

7. Select the device (with firmware) once more. 
 

 

An overview of the descriptions for these steps you find in the section 
Overview Settings on page 31. 

 

8. In the DTM interface dialog select the OK button, to apply the selection 
and to close the DTM interface dialog. 

9. Put a right-click on the EtherCAT Slave device icon. 

10. Select the Connect command from the context menu. 

 The EtherCAT Slave device now is connected to the EtherCAT Slave  
DTM via an online connection. In the network view the device 
description at the device icon of the Slave is displayed with a green 
colored background. 
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Disconnecting Device 
To disconnect an online connection from the EtherCAT Slave device to a 
EtherCAT Slave DTM take the following steps: 

1. In the DTM interface dialog select the OK button, to close the DTM 
interface dialog. 

2. Right-click on the EtherCAT Slave device icon. 

3. Select the Disconnect command from the context menu. 

 In the network view the device description at the device icon of the 
Slave is not any more displayed with a green colored background. Now 
the EtherCAT Slave device is disconnected from the DTM. 
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7.2 Download Configuration 
The device configuration is created offline in the DTM (application 
program). A download to the device is required, to transfer the configuration 
with the parameter data to the device.  
 

 
Note: To download configuration parameter data to the EtherCAT Slave 
device an online connection from the EtherCAT Slave DTM to the 
EtherCAT Slave device is required. Further information can be found in 
the Connecting/Disconnecting Device section on page 84. 

 

Safety Precautions 
If you plan to perform a configuration download via the EtherCAT Slave 
DTM be aware of the following: 
 

  
Communication Stop due to Configuration Download,  
Faulty System Operation possible or Loss of Device Parameters  
Before you initiate a configuration dowload process, while the bus is still in 
operation status: 
 Stop the application program. 

 Make sure that all network devices are placed in a fail-safe condition. 
 

  
Mismatching System Configuration,  
faulty System or Device Operation possible 
 In the device use only a configuration suitable for the system. 
 

 
 
 

 
Loss of Parameters caused by Power Disconnect during 
Configuration Download 
 During configuration download process, do not interrupt the power supply 

to the PC, or to the device and do not perform a reset to the device! 

For more see next page. 
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Download Steps 
To transfer the configuration with the corresponding parameter data to the 
EtherCAT Slave device you download the data using the frame application 
of the configuration software.  

For netDevice the download is made via Device > Download or use the 
context menu with Download. 

1. Select Download in the context menu of the device.  

 If the download is started as long as the Slave devices are connected to 
the Master device, the following message is displayed: ‘If you attempt to 
download during bus operation, communication between Master and 
Slaves is stopped. Do you really want to download?’ 

 
Figure 44: netDevice Message: Download 

 

Important: If the communication between the Master and the Slave 
devices is stopped, the data exchange between the Master device and the 
Slave devices is stopped. 

 

2. Click to Yes if you intend to download the configuration.  

 Then the current configuration in the application program is down 
loaded to the device. 

3. Otherwise click to No. 
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8 Diagnosis 
8.1 Overview Diagnosis 

The dialog Diagnosis serves to diagnose the device behavior and 
communication errors. For diagnosis the device must reside in online state.  

Diagnosis Panes 
The table below gives an overview for the individual Diagnosis dialog 
panes descriptions: 
 

EtherCAT Slave DTM Folder Name / Section Manual Page 

 
Navigation Area - Diagnosis 

General Diagnosis  89 

Firmware Diagnosis 91 

Table 38: Descriptions of the Diagnosis Panes 

Online Connection to the Device 

 
Note: Accessing the Diagnosis panes of the EtherCAT Slave DTM 
requires an online connection from the EtherCAT Slave DTM to the 
EtherCAT Slave device. For further information refer to section 
Connecting/Disconnecting Device on page 84. 

 
 

How to proceed 
1. In the Slave DTM diagnosis dialog check whether the communication is 

OK: 

Diagnosis > General Diagnosis > Device status "Communication" must 
be green! 

2. "Communication" is green: Open the IO Monitor and test the input or 
output data.. 

3. "Communication" is not green: Use Diagnosis and Extended 
diagnosis for troubleshooting. 

 
 

Extended Diagnosis 
The Extended Diagnosis helps to find communication and configuration 
errors, when default diagnosis fails. For further information refer to section 
Overview Extended Diagnosis on page 92. 
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8.2 General Diagnosis 
Information regarding the Device State and other general diagnosis 
parameters are displayed in the General Diagnosis dialog. 

 
Figure 45: General Diagnosis 

LED Meaning Color State 

Device State 

Communication Shows whether the EtherCAT device executes the 
network communication. 

 (green) In COMMUNICATION 
state 

 (gray) Not in 
COMMUNICATION state 

Run Shows whether the EtherCAT device has been 
configured correctly. 

 (green) Configuration OK 

 (gray) Configuration not OK 

Ready Shows whether the EtherCAT device has been 
started correctly. The EtherCAT device waits for a 
configuration. 

 (yellow) Device READY 

 (gray) Device not READY 

Error Shows whether the EtherCAT device records a 
device status error. For further information about the 
error characteristics and the number of counted 
errors refer to the extended diagnosis. 

 (red) ERROR 

 (gray) No ERROR 

Network State 

Operate Shows whether the EtherCAT device is in data 
exchange. In a cyclic data exchange the input data 
or the output data of the EtherCAT Slave are 
transmitted to the EtherCAT Master. 

 (green) In OPERATION state 

 (gray) Not  
in OPERATION state 

Idle Shows whether the EtherCAT device is in idle state.  (yellow) In IDLE state 

 (gray) Not in IDLE state 
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LED Meaning Color State 

Stop Shows whether the EtherCAT device is in Stop 
state: There is no cyclic data exchange at the 
EtherCAT network. The EtherCAT device was 
stopped by the application program or it changed to 
the Stop state because of a bus error. 

 (red) In STOP state 

 (gray) Not in STOP state 

Offline  The EtherCAT Slave is offline as long as it does not 
have a valid configuration. 

 (yellow) In OFFLINE state 

 (gray) Not in OFFLINE state 

Configuration State 

Configuration 
locked 

Shows whether the EtherCAT device configuration 
is locked, to avoid the configuration data are typed 
over. 

 (yellow) Configuration LOCKED 

 (gray) Configuration not 
LOCKED 

New Configura-
tion pending 

Shows whether a new EtherCAT device 
configuration is available. 

 (yellow) New Configuration 
pending 

 (gray) No new Configuration 
pending 

Reset required Shows whether a firmware reset is required as a 
new EtherCAT device configuration has been 
loaded into the device. 

 (yellow) RESET required 

 (gray) No RESET required 

Bus ON Shows whether the bus communication was started 
or stopped. I. e., whether the device is active on the 
bus or no bus communication to the device is 
possible and no response telegrams are sent. 

 (green) Bus ON 

 (gray) Bus OFF 

Table 39: Indication General Diagnosis 

 
 

Parameter Meaning 
Communication Error Shows the name of the communication error. If the cause of error is resolved, the value will be 

set to zero again. 

Watchdog time Shows the watchdog time in ms. 

Error Count This field holds the total number of errors detected since power-up, respectively after reset. 
The protocol stack counts all sorts of errors in this field no matter whether they were network 
related or caused internally. 

Table 40: Parameter General Diagnosis 
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8.3 Firmware Diagnosis 
In the dialog Firmware Diagnosis the current task information of the 
firmware is displayed.  

Under Firmware or Version the name of the firmware and version 
(including the date) are indicated. 
 

 
Figure 46: Firmware Diagnosis (Example) 

Task Information: 
The table Task Information is listing the task information of the single 
firmware tasks. 
 

Column Meaning 
Task Task number  

Name of task Name of the task 

Version Version number of the task 

Prio Priority of the task 

Description Description of the task 

Status Current status of the task 

Table 41: Description Table Task Information 

 
 



Extended Diagnosis  92/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

9 Extended Diagnosis 
9.1 Overview Extended Diagnosis 

The Extended Diagnosis of the EtherCAT Slave DTM helps to find 
communication and configuration errors. Therefore it contains a list of 
diagnosis structures as online counter, states and parameters.  

Dialog Panes “Extended Diagnosis” 
The table below gives an overview for the Extended Diagnosis dialog 
panes descriptions: 
 

EtherCAT Slave DTM Folder Name in the 
Navigation Area 

Subsection Page 

 
Navigation Area - Extended 
Diagnosis 

RX-SYSTEM Task Information  93 
 IniBatch Status 94 
DPM_COMO_SMBX Task Information  93 
DPM_COMO_RMBX Task Information  93 
ECAT_SDO Task Information  93 
 ECAT_SDO_RSC_DIAG_T 95 
 ECAT_SDO_RSC_TIMER_T 96 
ECAT_COE Task Information  93 
ECAT_ESM Task Information  93 
 ECAT_ESM_RSC_DIAG_T 97 
ECAT_MBX Task Information  93 
 ECAT_MBX_RSC_DIAG_T 98 
 ECAT_MBX_RSC_TIMER_T 99 
ECAT_DPM Task Information  93 
MARSHALLER Task Information  93 
PACKET_ROUTER Task Information  93 

Table 42: Descriptions of the Dialog Panes Extended Diagnosis 

Online Connection to the Device 

 
Note: Accessing the Extended Diagnosis dialog panes of the EtherCAT 
Slave DTM requires an online connection from the EtherCAT Slave DTM 
to the EtherCAT Slave device. For further information refer to section 
Connecting/Disconnecting Device on page 84. 
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9.2 Task Information 

 
Figure 47: Extended Diagnosis > [Folder Name] > Task Information Example Display 

Name Description 
Identifier Identification number of the task 

Major version Task version, contains incompatible changes 

Minor version Task version, contains compatible changes 

Maximum packet size Maximum packet size, which the task sends 

Default Queue Queue handle, which is accessible via DPM by mailbox. 

UUID Unique user ID, 16 Byte indicator used for task identification and its affiliation e. g. to a stack 
(therein different identification data are coded in). 

Init result Error Code, 0= no Error 
The description of the error codes can be found in this manual or in the corresponding 
software reference manuals. 

Table 43: Extended Diagnosis > [Folder Name] > Task Information 
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9.3 IniBatch Status 

 
Figure 48: Extended Diagnosis > [Folder Name] > IniBatch Status Example Display 

Name Description 
Communication Channel Number of the communication channel used by the device. 

Current State Idle; 
IniBatch packets in progress; 
Retrying to send last packet; 
Error 

IniBatch Result Ok; 
No DBM file; 
No Packet table; 
No data set available;  
Data set is shorter than packet length; 
Packet Buffer is shorter than Packet length; 
Invalid packet destination; 
Logical queue not defined 
Send packet failed; 
Too many retries; 
Error in confirmation packet status 

OpenDbm Result Error when opening the IniBatch data base 
Under "OpenDbm Result" the error code is typed in, when "IniBatch Result" == "No DBM 
file" (1) is. 

SendPacket Result Error when sending a packet 
Under "SendPacket Result" the error code is typed in, when "IniBatch Result" == “send 
packet failed" (8) is. 

Confirmation Result Confirmation error when sending packets 
Under "Confirmation Result" the packet specific error code from the ulSta is typed in, when 
"IniBatch Result " == "Error in confirmation packet status" (10) is. 

Last Packet Number Value depends by the communication system. 

Last Packet Command Value depends by the communication system. 

Last Packet Length Value depends by the communication system. 

Last Packet Destination Value depends by the communication system. 

Table 44:  Extended Diagnosis > [Folder Name] > IniBatch Status 

The task status "Confirmation Result" is bus specific. The other task 
statuses are rcx-related error codes. 
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9.4 ECAT_SDO_RSC_DIAG_T 

 
Figure 49: Extended Diagnosis > [Folder Name] > ECAT_SDO_RSC_DIAG_T Example 
Display 

This window lists the diagnostic counters of the ECAT_SDO_RSC_DIAG_T 
layer. It shows in particular, which services are currently executed. (The 
services of the packets are described within the EtherCAT-Slave Protocol 
API Manual [2].) 
 

Name Description 
ulCompletedDownloadsServer Counter for Completed Downloads at the Server 
ulCompletedUploadsServer Counter for Completed Uploads at the Server 
ulCompletedDownloadsClient Counter for Completed Downloads at the Client 
ulCompletedUploadsClient Counter for Completed Uploads at the Client 
ulAbortedDownloadsServer Counter for Aborted Downloads at the Server 
ulAbortedUploadsServer Counter for Aborted Uploads at the Server 
ulAbortedDownloadsClient Counter for Aborted Downloads at the Client 
ulAbortedUploadsClient Counter for Aborted Uploads at the Client 
ulServerTimeouts Counter for Server Timeouts 
ulClientTimeouts Counter for Client Timeouts 

Table 45: Extended Diagnosis > [Folder Name] > ECAT_SDO_RSC_DIAG_T 
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9.5 ECAT_SDO_RSC_TIMER_T 

 
Figure 50: Extended Diagnosis > [Folder Name] > ECAT_SDO_RSC_TIMER_T Example 
Display 

 

Name Description 
ulTimerCnt Timer count 
ulTimerGran Timer granularity 
ulSDOClientTimeout SDO Client Timeout 
ulSDOServerTimeout SDO Server Timeout 

Table 46: Extended Diagnosis > [Folder Name] > ECAT_SDO_RSC_TIMER_T 
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9.6 ECAT_ESM_RSC_DIAG_T 

 
Figure 51:  Extended Diagnosis > [Folder Name] > ECAT_ESM_RSC_DIAG_T Example 
Display 

This window lists the diagnostic counters of the ECAT_ESM_RSC_DIAG_T 
T layer. It shows in particular, which services are currently executed. (The 
services of the packets are described within the EtherCAT-Slave Protocol 
API Manual [2].) 
 

Name Description 
ulReadyBits Counter for Ready Bits 
ulSetInitBits Counter for SetInit Bits 
ulCorrectStateChanges Counter for correct state changes 
ulInvalidStateChanges Counter for invalid state changes 
ulErrorStateChanges Counter for error state changes 
ulInvalidStateRequested Counter for requested invalid states 
ulParameterFailures Counter for parameter failures 
ulTimeoutStateChanges Counter for timeout state changes 
ulAlStatus AL Status according to EtherCAT Specification, part 5 and 6 

Table 47: Extended Diagnosis > [Folder Name] > ECAT_ESM_RSC_DIAG_T 
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9.7 ECAT_MBX_RSC_DIAG_T 

 
Figure 52: Extended Diagnosis > [Folder Name] > ECAT_ESM_RSC_DIAG_T Example 
Display 

This window lists the diagnostic counters of the ECAT_MBX_RSC_DIAG_T 
layer. It shows in particular, which services are currently executed. (The 
services of the packets are described within the EtherCAT-Slave Protocol 
API Manual [2].) 
 

Name Description 
fGotPacketWaiting If TRUE, a packet is still waiting 
fActive If TRUE, the ECAT_MBX task is active 
ulMessagesReceived Counter for number of received messages 
ulMessagesSent Counter for number of sent messages 
ulMsgTooLong Counter for number of too long messages 

Table 48: Extended Diagnosis > [Folder Name] > ECAT_MBX_RSC_DIAG_T 

 

 



Extended Diagnosis  99/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

9.8 ECAT_MBX_RSC_TIMER_T 

 
Figure 53: Extended Diagnosis > [Folder Name] > ECAT_MBX_RSC_TIMER_T Example 
Display 

 

Name Description 
ulTimerGran Timer granularity 
ulTimerCnt Timer count 
ulLowtrafficTimeout Low traffic timeout 

Table 49: Extended Diagnosis > [Folder Name] > ECAT_MBX_RSC_TIMER_T 
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10 Tools 
10.1 Overview Tools 

Under Tools the Packet Monitor and the IO Monitor are provided for test 
and diagnosis purposes.  

Tools Panes 
The table below gives an overview for the individual Tools dialog panes 
descriptions: 
 

EtherCAT Slave DTM Folder Name / Section Manual Page 

 
Navigation Area - Tools 

Packet Monitor  101 

IO Monitor 104 

Table 50: Descriptions of the Diagnosis Panes 

Online Connection to the Device 

 
Note: Accessing the Tools dialog panes of the EtherCAT Slave DTM 
requires an online connection from the EtherCAT Slave DTM to the 
EtherCAT Slave device. For further information refer to section 
Connecting/Disconnecting Device on page 84. 
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10.2 Packet Monitor 
The Packet Monitor serves for test and diagnosis purposes.  

Data packets, i. e. messages are self-contained blocks of defined data 
length. The packets are used to communicate with the firmware and they 
are exchanged between the application (configuration software) and the 
firmware in the device. Packets can be sent once or cyclically to the 
connected device controlled by the user and packets received can be 
displayed. 

Data packets comprise from a Packet Header and the Send Data or from 
a Packet Header and the Receive Data. The packet header can be 
evaluated by the receiver of the packet and contain the sender and receiver 
address, the data length, an ID number, status and error messages and the 
command or response code. The minimum packet size amounts 40 Byte 
for the packet header. The sending and receiving data are added. 
 

 

For further information to the packet description refer to the Protocol API 
Manual.  

 Open the Packet Monitor via Tools > Packet Monitor. 

 
Figure 54: Packet Monitor 

Display Mode switches the representation of the send and reception data 
between decimal and hexadecimal. 

 Select Reset Counter to reset the packet counter. 



Tools  102/129 

DTM for Hilscher EtherCAT Slave Device | Configuration of Hilscher Slave Devices  
DOC110702OI06EN | Revision 6 | English | 2020-01 | Released | Public  © Hilscher, 2012-2020 

10.2.1 Sending Packet 

 
Figure 55: Send > Packet Header and Send Data 

Packet Header 
Under Send > Packet Header the elements of the packet header of the 
sending packet are displayed, which is transmitted from the application 
(configuration software) to the device. The packet header of the sending 
packets contain the elements described in the following table. 
 

Element Description 
Dest Destination Queue Handle Contains the identifier of the receiver for the packet (destination task 

queue of the firmware).  
Src Source Queue Handle Contains the identifier of the sender of the packet (sending task).  
Dest 
ID 

Destination Queue Reference Contains an identifier for the receiver of unsolicited sent packets from the 
firmware to the application (configuration software).  

Src ID Source Queue Reference Contains an identifier of the sender.  
Len Packet Data Length (in Bytes) Length of the send respectively receive data. 
ID Packet Identification As 

Unique Number  
Identifies identical data packets among each other. 

State Status / Error Code Transmits status or error codes to the packet sender. 
Cmd Command / Response Code Command or respond code.  
Ext Extension Field for extensions (reserved). 
Rout Routing Information Internal value of the firmware. 

Table 51: Descriptions Packet Header 

 

 Under Dest select the receiver (destination task queue). 

 Under Cmd select the command identification (Request). 

Auto Increment ID is an increment for the identifier of the data packets 
and increments the ID by 1 for each newly sent packet. 

Send Data 
 Under Send > Send data enter the send data of the packet, which shall 

be transmitted from the application (configuration software) to the 
mailbox of the device. The meaning of the transmitted data depends on 
the command or response code. 
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Sending Packets once or cyclic 
 To send packet once, select Put packet. 
 To send packet cyclic, select Put cyclic. 
 

10.2.2 Receiving Packet 

 
Figure 56: Packet Header and Receive Data 

Packet Header 
Under Receive > Packet Header the elements of the packet header of the 
receiving packet are displayed, which are transmitted back from the device 
to the application (configuration software). The packet header of the 
receiving packets contain the elements described in the following table. 
 

Element Description 
Dest Destination Queue Handle Contains the identifier of the receiver for the packet (destination task 

queue of the firmware).  
Src Source Queue Handle Contains the identifier of the sender of the packet (sending task).  
Dest ID Destination Queue Reference Contains an identifier for the receiver of unsolicited sent packets from 

the firmware to the application (configuration software).  
Src ID Source Queue Reference Contains an identifier of the sender.  
Len Packet Data Length (in Bytes) Length of the send respectively receive data. 
ID Packet Identification As 

Unique Number  
Identifies identical data packets among each other. 

State Status / Error Code Transmits status or error codes to the packet sender. 
Cmd Command / Response Code Command or respond code.  
Ext Extension Field for extensions (reserved). 
Rout Routing Information Internal value of the firmware. 

Table 52: Descriptions Packet Header 

Receive Data 
Under Receive > Receive Data the receiving data of the packet, which is 
transmitted back from the device to the application (configuration software) 
are displayed. 
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10.3 IO Monitor 
The IO Monitor serves for test and diagnosis purposes. It provides to view 
data of the process data image and to change output data easily. The 
display is always in a Byte manner.  
 

 
Note: Only change and write output data if you know that no plant 
disturbances are caused by this. All output data written by the IO Monitor 
are transmitted at the bus and have effect on subordinate drives, IO etc. 

 

 
Figure 57: IO Monitor 

Columns switches the number of columns.  

Display mode switches the representation of the input and output data 
between decimal and hexadecimal. 

Offset / Go moves the indication of the data to the entered offset value. 

 Enter the output value and select Update.  

 Always the data of the process image are displayed, also when these 
Bytes have not been reserved by the configuration.  
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11 Error Codes 
11.1 Error Code Definition 

For COM based application, like the ODM Server and ODM drivers, a 
common error definition is used, similar to the Microsoft Windows® 
HRESULT definition. 

Error Code Structure: 

COM Errors are HRESULTs, which are 32 bit values using the following 
layout: 

 3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1 

 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 

+---+-+-+-----------------------+-------------------------------+ 

|Sev|C|R|     Facility          |               Code            | 

+---+-+-+-----------------------+-------------------------------+ 

 

where 

Sev       - is the severity code: 

       00 - Success 

       01 - Informational 

       10 - Warning 

       11 - Error 

C         - is the Customer code flag 

R         - is a reserved bit 

Facility  - is the facility code 

Code      - is the facility's status code 

In this common error definition, several error code regions are already 
reserved by Windows® itself, the ODM and some other modules.  
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11.2 Overview Error Codes 
 
 

Overview Error Codes Range 

General Hardware Errors 
RCX Operating System 

RCX General Task: 0xC02B0001 to 0xC02B4D52 

RCX Common Status & Errors Codes: 0x00000000 to 0xC002000C 

RCX Status & Error Codes: 0x00000000 to 0xC0000008 

ODM Server General ODM Error Codes: 0x8004C700 to 0x8004C761 

General ODM Driver Error Codes: 0x8004C7A0 to 0x8004C7C2 

ODM Drivers cifX Driver Specific ODM Error: 0x8004C001 to 0x8004C0A4 

cifX Device Driver  
and netX Driver 

Generic Error: 0x800A0001 bis 0x800A0017 

Generic Driver Error: 0x800B0001 bis0x800B0042 

Generic Device Error: 0x800C0010 bis0x800C0041 

netX Driver CIFX API Transport: 0x800D0001 bis 0x800D0013 

CIFX API Transport Header State Error: 0x800E0001 bis 0x800E000B 

DBM ODM Error Codes: 0xC004C810 to 0xC004C878 

Table 53: Overview Error Codes and Ranges 

 
 

 

The fieldbus specific error codes are described in the manuals of the 
corresponding protocol tasks. 
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11.3 General Hardware Error Codes 

11.3.1 RCX General Task Errors 
 

Error Code (Definition) Value Description 
RCX_E_QUE_UNKNOWN 0xC02B0001 Unknown Queue 
RCX_E_QUE_INDEX_UNKNOWN 0xC02B0002 Unknown Queue Index 
RCX_E_TASK_UNKNOWN 0xC02B0003 Unknown Task 
RCX_E_TASK_INDEX_UNKNOWN 0xC02B0004 Unknown Task Index 
RCX_E_TASK_HANDLE_INVALID 0xC02B0005 Invalid Task Handle 
RCX_E_TASK_INFO_IDX_UNKNOWN 0xC02B0006 Unknown Index 
RCX_E_FILE_XFR_TYPE_INVALID 0xC02B0007 Invalid Transfer Type 
RCX_E_FILE_REQUEST_INCORRECT 0xC02B0008 Invalid File Request  
RCX_E_TASK_INVALID 0xC02B000E Invalid Task 
RCX_E_SEC_FAILED 0xC02B001D Security EEPROM Access Failed 
RCX_E_EEPROM_DISABLED 0xC02B001E EEPROM Disabled 
RCX_E_INVALID_EXT 0xC02B001F Invalid Extension 
RCX_E_SIZE_OUT_OF_RANGE 0xC02B0020 Block Size Out Of Range 
RCX_E_INVALID_CHANNEL 0xC02B0021 Invalid Channel 
RCX_E_INVALID_FILE_LEN 0xC02B0022 Invalid File Length 
RCX_E_INVALID_CHAR_FOUND 0xC02B0023 Invalid Character Found 
RCX_E_PACKET_OUT_OF_SEQ 0xC02B0024 Packet Out Of Sequence 
RCX_E_SEC_NOT_ALLOWED 0xC02B0025 Not Allowed In Current State 
RCX_E_SEC_INVALID_ZONE 0xC02B0026 Security EEPROM Invalid Zone 
RCX_E_SEC_EEPROM_NOT_AVAIL 0xC02B0028 Security EEPROM Eeprom Not Available 
RCX_E_SEC_INVALID_CHECKSUM 0xC02B0029 Security EEPROM Invalid Checksum 
RCX_E_SEC_ZONE_NOT_WRITEABLE 0xC02B002A Security EEPROM Zone Not Writeable 
RCX_E_SEC_READ_FAILED 0xC02B002B Security EEPROM Read Failed 
RCX_E_SEC_WRITE_FAILED 0xC02B002C Security EEPROM Write Failed 
RCX_E_SEC_ACCESS_DENIED 0xC02B002D Security EEPROM Access Denied 
RCX_E_SEC_EEPROM_EMULATED 0xC02B002E Security EEPROM Emulated 
RCX_E_INVALID_BLOCK 0xC02B0038 Invalid Block 
RCX_E_INVALID_STRUCT_NUMBER 0xC02B0039 Invalid Structure Number 
RCX_E_INVALID_CHECKSUM 0xC02B4352 Invalid Checksum 
RCX_E_CONFIG_LOCKED 0xC02B4B54 Configuration Locked 
RCX_E_SEC_ZONE_NOT_READABLE 0xC02B4D52 Security EEPROM Zone Not Readable 

Table 54: RCX General Task Errors 
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11.3.2 RCX Common Status & Errors Codes 
 

Error Code (Definition) Value Description 
RCX_S_OK 0x00000000 Success, Status Okay 
RCX_E_FAIL 0xC0000001 Fail 
RCX_E_UNEXPECTED 0xC0000002 Unexpected 
RCX_E_OUTOFMEMORY 0xC0000003 Out Of Memory 
RCX_E_UNKNOWN_COMMAND 0xC0000004 Unknown Command 
RCX_E_UNKNOWN_DESTINATION 0xC0000005 Unknown Destination 
RCX_E_UNKNOWN_DESTINATION_ID 0xC0000006 Unknown Destination ID 
RCX_E_INVALID_PACKET_LEN 0xC0000007 Invalid Packet Length 
RCX_E_INVALID_EXTENSION 0xC0000008 Invalid Extension 
RCX_E_INVALID_PARAMETER 0xC0000009 Invalid Parameter 
RCX_E_WATCHDOG_TIMEOUT 0xC000000C Watchdog Timeout 
RCX_E_INVALID_LIST_TYPE 0xC000000D Invalid List Type 
RCX_E_UNKNOWN_HANDLE 0xC000000E Unknown Handle 
RCX_E_PACKET_OUT_OF_SEQ 0xC000000F Out Of Sequence 
RCX_E_PACKET_OUT_OF_MEMORY 0xC0000010 Out Of Memory 
RCX_E_QUE_PACKETDONE 0xC0000011 Queue Packet Done 
RCX_E_QUE_SENDPACKET 0xC0000012 Queue Send Packet 
RCX_E_POOL_PACKET_GET 0xC0000013 Pool Packet Get 
RCX_E_POOL_GET_LOAD 0xC0000015 Pool Get Load 
RCX_E_REQUEST_RUNNING 0xC000001A Request Already Running 
RCX_E_INIT_FAULT 0xC0000100 Initialization Fault 
RCX_E_DATABASE_ACCESS_FAILED 0xC0000101 Database Access Failed 
RCX_E_NOT_CONFIGURED 0xC0000119 Not Configured 
RCX_E_CONFIGURATION_FAULT 0xC0000120 Configuration Fault 
RCX_E_INCONSISTENT_DATA_SET 0xC0000121 Inconsistent Data Set 
RCX_E_DATA_SET_MISMATCH 0xC0000122 Data Set Mismatch 
RCX_E_INSUFFICIENT_LICENSE 0xC0000123 Insufficient License 
RCX_E_PARAMETER_ERROR 0xC0000124 Parameter Error 
RCX_E_INVALID_NETWORK_ADDRESS 0xC0000125 Invalid Network Address 
RCX_E_NO_SECURITY_MEMORY 0xC0000126 No Security Memory 
RCX_E_NETWORK_FAULT 0xC0000140 Network Fault 
RCX_E_CONNECTION_CLOSED 0xC0000141 Connection Closed 
RCX_E_CONNECTION_TIMEOUT 0xC0000142 Connection Timeout 
RCX_E_LONELY_NETWORK 0xC0000143 Lonely Network 
RCX_E_DUPLICATE_NODE 0xC0000144 Duplicate Node 
RCX_E_CABLE_DISCONNECT 0xC0000145 Cable Disconnected 
RCX_E_BUS_OFF 0xC0000180 Network Node Bus Off 
RCX_E_CONFIG_LOCKED 0xC0000181 Configuration Locked 
RCX_E_APPLICATION_NOT_READY 0xC0000182 Application Not Ready 
RCX_E_TIMER_APPL_PACKET_SENT 0xC002000C Timer App Packet Sent 

Table 55: RCX Common Status & Errors Codes 
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11.3.3 RCX Status & Error Codes 
 

Error Code (Definition) Value Description 
RCX_S_OK  0x00000000 SUCCESS, STATUS OKAY  
RCX_S_QUE_UNKNOWN  0xC02B0001 UNKNOWN QUEUE  
RCX_S_QUE_INDEX_UNKNOWN  0xC02B0002 UNKNOWN QUEUE INDEX 
RCX_S_TASK_UNKNOWN 0xC02B0003 UNKNOWN TASK  
RCX_S_TASK_INDEX_UNKNOWN 0xC02B0004 UNKNOWN TASK INDEX  
RCX_S_TASK_HANDLE_INVALID 0xC02B0005 INVALID TASK HANDLE  
RCX_S_TASK_INFO_IDX_UNKNOWN 0xC02B0006 UNKNOWN INDEX  
RCX_S_FILE_XFR_TYPE_INVALID 0xC02B0007 INVALID TRANSFER TYPE  
RCX_S_FILE_REQUEST_INCORRECT 0xC02B0008 INVALID FILE REQUEST  
RCX_S_UNKNOWN_DESTINATION 0xC0000005 UNKNOWN DESTINATION  
RCX_S_UNKNOWN_DESTINATION_ID 0xC0000006 UNKNOWN DESTINATION ID  
RCX_S_INVALID_LENGTH 0xC0000007 INVALID LENGTH  
RCX_S_UNKNOWN_COMMAND 0xC0000004 UNKNOWN COMMAND  
RCX_S_INVALID_EXTENSION 0xC0000008 INVALID EXTENSION  

Table 56: RCX Status & Error Codes 

 

11.3.3.1 RCX Status & Error Codes Slave State 
 

Error Code (Definition) Value Description 
RCX_SLAVE_STATE_UNDEFINED 0x00000000 UNDEFINED 
RCX_SLAVE_STATE_OK 0x00000001 OK 
RCX_SLAVE_STATE_FAILED 0x00000002 FAILED (at least one slave) 

Table 57: RCX Status & Error Codes Slave State 
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11.4 ODM Error Codes 
 

11.4.1 General ODM Error Codes 
 

Error Code (Definition) Value Description 

CODM3_E_INTERNALERROR 0x8004C700 Internal ODM Error 

ODM3_E_DESCRIPTION_NOTFOUND 0x8004C701 Description not found in ODM database 

CODM3_E_WRITEREGISTRY 0x8004C710 Error writing to the registry 

CODM3_E_BAD_REGULAR_EXPRESSION 0x8004C711 Invalid regular expression 

CODM3_E_COMCATEGORIE_MANAGER_ 
FAILED 

0x8004C712 Component Category Manager could not 
be instantiated 

CODM3_E_COMCATEGORIE_ENUMERATION_
FAILED 

0x8004C713 Driver could not be enumerated by the 
Category Manager 

CODM3_E_CREATE_LOCAL_BUFFER 0x8004C714 Error creating local buffers 

CODM3_E_UNKNOWNHANDLE 0x8004C715 Unknown handle 

CODM3_E_QUEUE_LIMIT_REACHED 0x8004C717 Queue size limit for connection reached 

CODM3_E_DATASIZE_ZERO 0x8004C718 Zero data length passed 

CODM3_E_INVALID_DATA 0x8004C719 Invalid data content 

CODM3_E_INVALID_MODE 0x8004C71A Invalid mode 

CODM3_E_DATABASE_READ 0x8004C71B Error reading database 

CODM3_E_CREATE_DEVICE_THREAD 0x8004C750 Error creating device thread 

CODM3_E_CREATE_DEVICE_THREAD_STOP_
EVENT 

0x8004C751 Error creating device thread stop event 

CODM3_E_CLIENT_NOT_REGISTERED 0x8004C752 Client is not registered at the ODM 

CODM3_E_NO_MORE_CLIENTS 0x8004C753 Maximum number of clients reached 

CODM3_E_MAX_CLIENT_CONNECTIONS_ 
REACHED 

0x8004C754 Maximum number of client connections 
reached 

CODM3_E_ENTRY_NOT_FOUND 0x8004C755 Driver/device not found 

CODM3_E_DRIVER_NOT_FOUND 0x8004C757 The requested driver is unknown to the 
ODM 

CODM3_E_DEVICE_ALREADY_LOCKED 0x8004C758 Device is locked by another process 

CODM3_E_DEVICE_UNLOCKED_FAILED 0x8004C759 Device could not be unlocked, lock was 
set by another process 

CODM3_E_DEVICE_LOCK_NECCESSARY 0x8004C75A Operation requires a device lock to be set 

CODM3_E_DEVICE_SUBSCRIPTIONLIMIT 0x8004C75B Maximum number of servers registered for 
this device reached 

CODM3_E_DEVICE_NOTSUBSCRIBED 0x8004C75C Process is not registered as a server on 
this device 

CODM3_E_DEVICE_NO_MESSAGE 0x8004C75D No message available 

CODM3_E_TRANSFERTIMEOUT 0x8004C760 Message transfer timeout 

CODM3_E_MESSAGE_INSERVICE 0x8004C761 Message in service 

Table 58: ODM Error Codes - General ODM Error Codes 
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11.4.2 General ODM Driver Error Codes 
 

Error Code (Definition) Value Description 
CODM3_E_DRV_OPEN_DEVICE 0x8004C7A0 Packet type unsupported by driver 
CODM3_E_DRV_INVALID_IDENTIFIER 0x8004C7A1 Invalid device identifier 
CODM3_E_DRV_DEVICE_PARAMETERS_ 
MISMATCH 

0x8004C7A3 Parameters differ from requested device 

CODM3_E_DRV_BROWSE_NO_DEVICES 0x8004C7A4 No devices found 
CODM3_E_DRV_CREATE_DEVICE_INST 0x8004C7A5 Device instance could not be created 
CODM3_E_DRV_DEVICE_NOMORE_TX 0x8004C7A6 Device connection limit reached 
CODM3_E_DRV_DEVICE_DUPLICATE_TX 0x8004C7A7 Duplicate transmitter ID 
CODM3_E_DRV_DEVICE_NOT_CONFIGURED 0x8004C7A8 Device is not configured 
CODM3_E_DRV_DEVICE_COMMUNICATION 0x8004C7A9 Device communication error 
CODM3_E_DRV_DEVICE_NO_MESSAGE 0x8004C7AA No message available 
CODM3_E_DRV_DEVICE_NOT_READY 0x8004C7AB Device not ready 
CODM3_E_DRV_INVALIDCONFIGURATION 0x8004C7AC Invalid driver configuration 
CODM3_E_DRV_DLINVALIDMODE 0x8004C7C0 Invalid download mode 
CODM3_E_DRV_DLINPROGRESS 0x8004C7C1 Download is active 
CODM3_E_DRV_ULINPROGRESS 0x8004C7C2 Upload is active 

Table 59: ODM Error Codes - General ODM Driver Error Codes 
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11.4.3 cifX Driver Specific ODM Error Codes 
 

 

cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_BOARD_NOT_INITIALIZED 0x8004C001 DRIVER Board not initialized 
DRV_E_INIT_STATE_ERROR 0x8004C002 DRIVER Error in internal init state 
DRV_E_READ_STATE_ERROR 0x8004C003 DRIVER Error in internal read state 
DRV_E_CMD_ACTIVE 0x8004C004 DRIVER Command on this channel is 

active 
DRV_E_PARAMETER_UNKNOWN 0x8004C005 DRIVER Unknown parameter in function 
DRV_E_WRONG_DRIVER_VERSION 0x8004C006 DRIVER Version is incompatible with DLL 
DRV_E_PCI_SET_CONFIG_MODE 0x8004C007 DRIVER Error during PCI set configuration 

mode 

DRV_E_PCI_READ_DPM_LENGTH 0x8004C008 DRIVER Could not read PCI dual port 
memory length 

DRV_E_PCI_SET_RUN_MODE 0x8004C009 DRIVER Error during PCI set run mode 
DRV_E_DEV_DPM_ACCESS_ERROR 0x8004C00A DEVICE Dual port ram not 

accessable(board not found) 
DRV_E_DEV_NOT_READY 0x8004C00B DEVICE Not ready (ready flag failed) 
DRV_E_DEV_NOT_RUNNING 0x8004C00C DEVICE Not running (running flag failed) 
DRV_E_DEV_WATCHDOG_FAILED 0x8004C00D DEVICE Watchdog test failed 
DRV_E_DEV_OS_VERSION_ERROR 0x8004C00E DEVICE Signals wrong OS version 
DRV_E_DEV_SYSERR 0x8004C00F DEVICE Error in dual port flags 
DRV_E_DEV_MAILBOX_FULL 0x8004C010 DEVICE Send mailbox is full 
DRV_E_DEV_PUT_TIMEOUT 0x8004C011 DEVICE PutMessage timeout 
DRV_E_DEV_GET_TIMEOUT 0x8004C012 DEVICE GetMessage timeout 
DRV_E_DEV_GET_NO_MESSAGE 0x8004C013 DEVICE No message available 
DRV_E_DEV_RESET_TIMEOUT 0x8004C014 DEVICE RESET command timeout 
DRV_E_DEV_NO_COM_FLAG 0x8004C015 DEVICE COM-flag not set. Check if Bus is 

running 
DRV_E_DEV_EXCHANGE_FAILED 0x8004C016 DEVICE I/O data exchange failed 
DRV_E_DEV_EXCHANGE_TIMEOUT 0x8004C017 DEVICE I/O data exchange timeout 
DRV_E_DEV_COM_MODE_UNKNOWN 0x8004C018 DEVICE I/O data mode unknown 
DRV_E_DEV_FUNCTION_FAILED 0x8004C019 DEVICE Function call failed 
DRV_E_DEV_DPMSIZE_MISMATCH 0x8004C01A DEVICE DPM size differs from 

configuration 
DRV_E_DEV_STATE_MODE_UNKNOWN 0x8004C01B DEVICE State mode unknown 
DRV_E_DEV_HW_PORT_IS_USED 0x8004C01C DEVICE Output port already in use 
DRV_E_USR_OPEN_ERROR 0x8004C01E USER Driver not opened (device driver not 

loaded) 
DRV_E_USR_INIT_DRV_ERROR 0x8004C01F USER Can't connect to device 
DRV_E_USR_NOT_INITIALIZED 0x8004C020 USER Board not initialized (DevInitBoard 

not called) 
DRV_E_USR_COMM_ERR 0x8004C021 USER IOCTRL function failed 
DRV_E_USR_DEV_NUMBER_INVALID 0x8004C022 USER Parameter DeviceNumber invalid 
DRV_E_USR_INFO_AREA_INVALID 0x8004C023 USER Parameter InfoArea unknown 
DRV_E_USR_NUMBER_INVALID 0x8004C024 USER Parameter Number invalid 
DRV_E_USR_MODE_INVALID 0x8004C025 USER Parameter Mode invalid 
DRV_E_USR_MSG_BUF_NULL_PTR 0x8004C026 USER NULL pointer assignment 
DRV_E_USR_MSG_BUF_TOO_SHORT 0x8004C027 USER Message buffer too small 
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cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_USR_SIZE_INVALID 0x8004C028 USER Parameter Size invalid 
DRV_E_USR_SIZE_ZERO 0x8004C02A USER Parameter Size with zero length 
DRV_E_USR_SIZE_TOO_LONG 0x8004C02B USER Parameter Size too long 
DRV_E_USR_DEV_PTR_NULL 0x8004C02C USER Device address null pointer 
DRV_E_USR_BUF_PTR_NULL 0x8004C02D USER Pointer to buffer is a null pointer 
DRV_E_USR_SENDSIZE_TOO_LONG 0x8004C02E USER Parameter SendSize too large 
DRV_E_USR_RECVSIZE_TOO_LONG 0x8004C02F USER Parameter ReceiveSize too large 
DRV_E_USR_SENDBUF_PTR_NULL 0x8004C030 USER Pointer to send buffer is a null 

pointer 
DRV_E_USR_RECVBUF_PTR_NULL 0x8004C031 USER Pointer to receive buffer is a null 

pointer 

DRV_E_DMA_INSUFF_MEM 0x8004C032 DMA Memory allocation error 
DRV_E_DMA_TIMEOUT_CH4 0x8004C033 DMA Read I/O timeout 
DRV_E_DMA_TIMEOUT_CH5 0x8004C034 DMA Write I/O timeout 
DRV_E_DMA_TIMEOUT_CH6 0x8004C035 DMA PCI transfer timeout 
DRV_E_DMA_TIMEOUT_CH7 0x8004C036 DMA Download timeout 
DRV_E_DMA_DB_DOWN_FAIL 0x8004C037 DMA Database download failed 
DRV_E_DMA_FW_DOWN_FAIL 0x8004C038 DMA Firmware download failed 
DRV_E_CLEAR_DB_FAIL 0x8004C039 DMA Clear database on the device failed 
DRV_E_DEV_NO_VIRTUAL_MEM 0x8004C03C DMA USER Virtual memory not available 
DRV_E_DEV_UNMAP_VIRTUAL_MEM 0x8004C03D DMA USER Unmap virtual memory failed 
DRV_E_GENERAL_ERROR 0x8004C046 DRIVER General error 
DRV_E_DMA_ERROR 0x8004C047 DRIVER General DMA error 
DRV_E_WDG_IO_ERROR 0x8004C048 DRIVER I/O WatchDog failed 
DRV_E_WDG_DEV_ERROR 0x8004C049 DRIVER Device Watchdog failed 
DRV_E_USR_DRIVER_UNKNOWN 0x8004C050 USER Driver unknown 
DRV_E_USR_DEVICE_NAME_INVALID 0x8004C051 USER Device name invalid 
DRV_E_USR_DEVICE_NAME_UKNOWN 0x8004C052 USER Device name unknown 

DRV_E_USR_DEVICE_FUNC_NOTIMPL 0x8004C053 USER Device function not implemented 

DRV_E_USR_FILE_OPEN_FAILED 0x8004C064 USER File could not be opened 

DRV_E_USR_FILE_SIZE_ZERO 0x8004C065 USER File size zero 

DRV_E_USR_FILE_NO_MEMORY 0x8004C066 USER Not enough memory to load file 

DRV_E_USR_FILE_READ_FAILED 0x8004C067 USER File read failed 

DRV_E_USR_INVALID_FILETYPE 0x8004C068 USER File type invalid 

DRV_E_USR_FILENAME_INVALID 0x8004C069 USER Invalid filename 

DRV_E_FW_FILE_OPEN_FAILED 0x8004C06E USER Firmware file could not be opened 

DRV_E_FW_FILE_SIZE_ZERO 0x8004C06F USER Not enough memory to load 
firmware file 

DRV_E_FW_FILE_NO_MEMORY 0x8004C070 USER Not enough memory to load 
firmware file 

DRV_E_FW_FILE_READ_FAILED 0x8004C071 USER Firmware file read failed 

DRV_E_FW_INVALID_FILETYPE 0x8004C072 USER Firmware file type invalid 

DRV_E_FW_FILENAME_INVALID 0x8004C073 USER Firmware file name not valid 

DRV_E_FW_DOWNLOAD_ERROR 0x8004C074 USER Firmware file download error 

DRV_E_FW_FILENAME_NOT_FOUND 0x8004C075 USER Firmware file not found in the 
internal table 

DRV_E_FW_BOOTLOADER_ACTIVE 0x8004C076 USER Firmware file BOOTLOADER active 
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cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_FW_NO_FILE_PATH 0x8004C077 USER Firmware file no file path 

DRV_E_CF_FILE_OPEN_FAILED 0x8004C078 USER Configuration file could not be 
opend 

DRV_E_CF_FILE_SIZE_ZERO 0x8004C079 USER Configuration file size zero 

DRV_E_CF_FILE_NO_MEMORY 0x8004C07A USER Not enough memory to load 
configuration file 

DRV_E_CF_FILE_READ_FAILED 0x8004C07B USER Configuration file read failed 

DRV_E_CF_INVALID_FILETYPE 0x8004C07C USER Configuration file type invalid 

DRV_E_CF_FILENAME_INVALID 0x8004C07D USER Configuration file name not valid 

DRV_E_CF_DOWNLOAD_ERROR 0x8004C07E USER Configuration file download error 

DRV_E_CF_FILE_NO_SEGMENT 0x8004C07F USER No flash segment in the 
configuration file 

DRV_E_CF_DIFFERS_FROM_DBM 0x8004C080 USER Configuration file differs from 
database 

DRV_E_DBM_SIZE_ZERO 0x8004C083 USER Database size zero 

DRV_E_DBM_NO_MEMORY 0x8004C084 USER Not enough memory to upload 
database 

DRV_E_DBM_READ_FAILED 0x8004C085 USER Database read failed 

DRV_E_DBM_NO_FLASH_SEGMENT 0x8004C086 USER Database segment unknown 

DEV_E_CF_INVALID_DESCRIPT_VERSION 0x8004C096 CONFIG Version of the descript table 
invalid 

DEV_E_CF_INVALID_INPUT_OFFSET 0x8004C097 CONFIG Input offset is invalid 

DEV_E_CF_NO_INPUT_SIZE 0x8004C098 CONFIG Input size is 0 

DEV_E_CF_MISMATCH_INPUT_SIZE 0x8004C099 CONFIG Input size does not match 
configuration 

DEV_E_CF_INVALID_OUTPUT_OFFSET 0x8004C09A CONFIG Invalid output offset 

DEV_E_CF_NO_OUTPUT_SIZE 0x8004C09B CONFIG Output size is 0 

DEV_E_CF_MISMATCH_OUTPUT_SIZE 0x8004C09C CONFIG Output size does not match 
configuration 

DEV_E_CF_STN_NOT_CONFIGURED 0x8004C09D CONFIG Station not configured 

DEV_E_CF_CANNOT_GET_STN_CONFIG 0x8004C09E CONFIG Cannot get the Station 
configuration 

DEV_E_CF_MODULE_DEF_MISSING 0x8004C09F CONFIG Module definition is missing 

DEV_E_CF_MISMATCH_EMPTY_SLOT 0x8004C0A0 CONFIG Empty slot mismatch 

DEV_E_CF_MISMATCH_INPUT_OFFSET 0x8004C0A1 CONFIG Input offset mismatch 

DEV_E_CF_MISMATCH_OUTPUT_OFFSET 0x8004C0A2 CONFIG Output offset mismatch 

DEV_E_CF_MISMATCH_DATA_TYPE 0x8004C0A3 CONFIG Data type mismatch 

DEV_E_CF_MODULE_DEF_MISSING_NO_SI 0x8004C0A4 CONFIG Module definition is missing,(no 
Slot/Idx) 

Table 60: cifX Driver Specific ODM Error Codes 
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11.5 Error Codes cifX Device Driver and netX Driver 
 

11.5.1 Generic Error Codes 
 
 

Error Code (Definition) Value Description 
CIFX_INVALID_POINTER  0x800A0001L Invalid pointer (NULL) passed to driver 
CIFX_INVALID_BOARD  0x800A0002L No board with the given nameindex 

available 
CIFX_INVALID_CHANNEL  0x800A0003L No channel with the given index 

available 
CIFX_INVALID_HANDLE 0x800A0004L Invalid handle passed to driver 
CIFX_INVALID_PARAMETER  0x800A0005L Invalid parameter 
CIFX_INVALID_COMMAND 0x800A0006L Invalid command 
CIFX_INVALID_BUFFERSIZE  0x800A0007L Invalid buffer size 
CIFX_INVALID_ACCESS_SIZE 0x800A0008L Invalid access size 
CIFX_FUNCTION_FAILED  0x800A0009L Function failed 
CIFX_FILE_OPEN_FAILED  0x800A000AL File could not be opened 
CIFX_FILE_SIZE_ZERO 0x800A000BL File size is zero 
CIFX_FILE_LOAD_INSUFF_MEM  0x800A000CL Insufficient memory to load file 
CIFX_FILE_CHECKSUM_ERROR  0x800A000DL File checksum compare failed 
CIFX_FILE_READ_ERROR  0x800A000EL Error reading from file 
CIFX_FILE_TYPE_INVALID  0x800A000FL Invalid file type 
CIFX_FILE_NAME_INVALID 0x800A0010L Invalid file name 
CIFX_FUNCTION_NOT_AVAILABLE 0x800A0011L Driver function not available 
CIFX_BUFFER_TOO_SHORT 0x800A0012L Given buffer is too short 
CIFX_MEMORY_MAPPING_FAILED  0x800A0013L Failed to map the memory 
CIFX_NO_MORE_ENTRIES 0x800A0014L No more entries available 
CIFX_CALLBACK_MODE_UNKNOWN  0x800A0015L Unkown callback handling mode 
CIFX_CALLBACK_CREATE_EVENT_FAILED  0x800A0016L Failed to create callback events 
CIFX_CALLBACK_CREATE_RECV_BUFFER  0x800A0017L Failed to create callback receive buffer 

Table 61: Generic Error Codes 
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11.5.2 Generic Driver Error Codes 
 

Error Code (Definition) Value Description 
CIFX_DRV_NOT_INITIALIZED  0x800B0001L Driver not initialized 
CIFX_DRV_INIT_STATE_ERROR 0x800B0002L Driver init state error 
CIFX_DRV_READ_STATE_ERROR 0x800B0003L Driver read state error 
CIFX_DRV_CMD_ACTIVE 0x800B0004L Command is active on device 
CIFX_DRV_DOWNLOAD_FAILED  0x800B0005L General error during download 
CIFX_DRV_WRONG_DRIVER_VERSION 0x800B0006L Wrong driver version 
CIFX_DRV_DRIVER_NOT_LOADED  0x800B0030L CIFx driver is not running 
CIFX_DRV_INIT_ERROR 0x800B0031L Failed to initialize the device 
CIFX_DRV_CHANNEL_NOT_INITIALIZED  0x800B0032L Channel not initialized (xOpenChannel 

not called) 
CIFX_DRV_IO_CONTROL_FAILED  0x800B0033L IOControl call failed 
CIFX_DRV_NOT_OPENED( 0x800B0034L Driver was not opened 
CIFX_DRV_DOWNLOAD_STORAGE_UNKN
OWN 

0x800B0040L Unknown download storage type 
(RAMFLASH based) found 

CIFX_DRV_DOWNLOAD_FW_WRONG_CHA
NNEL 

0x800B0041L Channel number for a firmware 
download not supported 

CIFX_DRV_DOWNLOAD_MODULE_NO_BAS
EOS  

0x800B0042L Modules are not allowed without a Base 
OS firmware 

Table 62: Generic Driver Error Codes 
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11.5.3 Generic Device Error Codes 
 

Error Code (Definition) Value Description 
CIFX_DEV_DPM_ACCESS_ERROR 0x800C0010L Dual port memory not accessable 

(board not found) 
CIFX_DEV_NOT_READY  0x800C0011L Device not ready (ready flag failed) 
CIFX_DEV_NOT_RUNNING  0x800C0012L Device not running (running flag failed) 
CIFX_DEV_WATCHDOG_FAILED  0x800C0013L Watchdog test failed 
CIFX_DEV_SYSERR 0x800C0015L Error in handshake flags 
CIFX_DEV_MAILBOX_FULL 0x800C0016L Send mailbox is full 
CIFX_DEV_PUT_TIMEOUT  0x800C0017L Send packet timeout 
CIFX_DEV_GET_TIMEOUT  0x800C0018L Receive packet timeout 
CIFX_DEV_GET_NO_PACKET  0x800C0019L No packet available 
CIFX_DEV_MAILBOX_TOO_SHORT  0x800C001AL Mailbox too short 
CIFX_DEV_RESET_TIMEOUT  0x800C0020L Reset command timeout 
CIFX_DEV_NO_COM_FLAG  0x800C0021L COM-flag not set 
CIFX_DEV_EXCHANGE_FAILED  0x800C0022L IO data exchange failed 
CIFX_DEV_EXCHANGE_TIMEOUT 0x800C0023L IO data exchange timeout 
CIFX_DEV_COM_MODE_UNKNOWN 0x800C0024L Unknown IO exchange mode 
CIFX_DEV_FUNCTION_FAILED  0x800C0025L Device function failed 
CIFX_DEV_DPMSIZE_MISMATCH 0x800C0026L DPM size differs from configuration 
CIFX_DEV_STATE_MODE_UNKNOWN 0x800C0027L Unknown state mode 
CIFX_DEV_HW_PORT_IS_USED  0x800C0028L Device is still accessed 
CIFX_DEV_CONFIG_LOCK_TIMEOUT  0x800C0029L Configuration locking timeout 
CIFX_DEV_CONFIG_UNLOCK_TIMEOUT  0x800C002AL Configuration unlocking timeout 
CIFX_DEV_HOST_STATE_SET_TIMEOUT 0x800C002BL Set HOST state timeout 
CIFX_DEV_HOST_STATE_CLEAR_TIMEOUT  0x800C002CL Clear HOST state timeout 
CIFX_DEV_INITIALIZATION_TIMEOUT 0x800C002DL Timeout during channel initialization 
CIFX_DEV_BUS_STATE_ON_TIMEOUT 0x800C002EL Set Bus ON Timeout 
CIFX_DEV_BUS_STATE_OFF_TIMEOUT  0x800C002FL Set Bus OFF Timeout 
CIFX_DEV_MODULE_ALREADY_RUNNING 0x800C0040L Module already running 
CIFX_DEV_MODULE_ALREADY_EXISTS  0x800C0041L Module already exists 

Table 63: Generic Device Error Codes 
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11.6 Error Codes netX Driver 
 

11.6.1 CIFX API Transport Error Codes 
 

Error Code (Definition) Value Description 
CIFX_TRANSPORT_SEND_TIMEOUT 0x800D0001L Time out while sending data 
CIFX_TRANSPORT_RECV_TIMEOUT 0x800D0002L Time out waiting for incoming data 
CIFX_TRANSPORT_CONNECT  0x800D0003L Unable to communicate to the deviceno 

answer 
CIFX_TRANSPORT_ABORTED  0x800D0004L Transfer has been aborted due to keep 

alive timeout or interface detachment 
CIFX_CONNECTOR_FUNCTIONS_READ_ERR
OR  

0x800D0010L Error reading the connector functions 
from the DLL 

CIFX_CONNECTOR_IDENTIFIER_TOO_LONG  0x800D0011L Connector delivers an identifier longer 
than 6 characters 

CIFX_CONNECTOR_IDENTIFIER_EMPTY 0x800D0012L Connector delivers an empty dentifier 
CIFX_CONNECTOR_DUPLICATE_IDENTIFIER  0x800D0013L Connector identifier already used 

Table 64: CIFX API Transport Error Codes 

 

 

11.6.2 CIFX API Transport Header State Error Codes 
 

Error Code (Definition) Value Description 
CIFX_TRANSPORT_ERROR_UNKNOWN  0x800E0001L Unknown error code in transport header 
CIFX_TRANSPORT_CHECKSUM_ERROR 0x800E0002L CRC16 checksum failed 
CIFX_TRANSPORT_LENGTH_INCOMPLETE  0x800E0003L Transaction with inclomplete length 

detected 
CIFX_TRANSPORT_DATA_TYPE_UNKOWN 0x800E0004L Device does not support requested data 

type 
CIFX_TRANSPORT_DEVICE_UNKNOWN 0x800E0005L Device not availableunknown 
CIFX_TRANSPORT_CHANNEL_UNKNOWN  0x800E0006L Channel not availableunknown 
CIFX_TRANSPORT_SEQUENCE 0x800E0007L Sequence error detected 
CIFX_TRANSPORT_BUFFEROVERFLOW 0x800E0008L Buffer overflow detected 
CIFX_TRANSPORT_RESOURCE 0x800E0009L Device signals out of resources 
CIFX_TRANSPORT_KEEPALIVE  0x800E000AL Device connection monitoring error 

(Keep alive) 
CIFX_TRANSPORT_DATA_TOO_SHORT( 0x800E000BL Received transaction data too short 

Table 65: CIFX API Transport Header State Error Codes 
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11.7 ODM Error Codes DBM V4 
 

 

ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_MD5_INVALID 0XC004C810 Checksum invalid 
CDBM_E_INTERNALERROR 0XC004C811 Internal Error 
CDBM_W_WRITEREGISTRY 0X8004C812 Error writing to the registry 
CDBM_E_UNEXPECTED_VALUE_ 
IN_OLD_HEADER_FORMAT 

0XC004C813 Error in a file containing the old DBM 
Header format. 

CDBM_E_CHECKSUM_INVALID 0XC004C814 The Checksum of the old Header is invalid 
CDBM_E_DB_ALREADY_LOADED_ FORMAT 0XC004C815 A database is already loaded 
CDBM_E_NO_VALID_TRANSACTION 0XC004C816 No valid transaction handle given 
CDBM_E_STD_STRUCT_ERROR 0XC004C817 An error occurred during validation of data 
CDBM_E_UNSUPPORTED_ 
DATA_TYPE_FORMAT 

0XC004C818 Unsupported DataType 

CDBM_W_CLASS_DELETED_ FORMAT 0X8004C819 
(Warning) 

Using an Object which is marked as 
deleted 

CDBM_W_CLIENT_DISCONNECTED 0X8004C81A 
(Warning) 

A Client has already an outstanding 
connection to a Table. The connection is 
now destroyed. 

CDBM_E_STRUCTURE_DEFINITION_ INVALID 0XC004C81B A structure definition of an Element in a 
Table is invalid 

CDBM_E_NO_DATA_AVAILABLE 0XC004C81C No data available for this operation 
CDBM_E_NO_VALID_STRUCTURE 0XC004C81D No valid structure available for this 

operation 
CDBM_E_NO_TOGGLE_STRING_ FOUND 0XC004C81E No Toggle string found for this number 
CDBM_E_ELEMENT_OUT_OF_RANGE 0XC004C81F An element wasn’t found in the Record of 

a Table 
CDBM_E_ELEMENT_NOT_IN_ TABLE 0XC004C820 The element is not part of the Table 
CDBM_E_CANNOT_CONVERT_ 
INTO_CLIENT_TYPE 

0XC004C821 The data can't be converted into the Client 
type 

CDBM_E_TRANSACTION_ ALREADY_OPEN 0XC004C822 A transaction is already open. Please 
close this one first before opening a new 
one. 

CDBM_I_OLD_WITHOUT_HEADER 0X4004C823 
(Informational) 

Use of an old DBM file Format without 
Header 

CDBM_E_HR_FROM 0XC004C824 An HRESULT was received from a 
Subroutine 

CDBM_E_PARAMETER 0XC004C825 A Parameter is invalid 
CDBM_E_NOTIMPL 0XC004C826 Method is currently not implemented 
CDBM_E_OUTOFMEMORY 0XC004C827 Out of memory 
CDBM_E_NO_OPEN_TRANSACTION 0XC004C828 No transaction open 
CDBM_E_NO_CONTENTS 0XC004C829 No contents available 
CDBM_REC_NO_NOT_FOUND 0XC004C82A Record not found 
CDBM_STRUCTURE_ELEMENT_ NOT_FOUND 0XC004C82B Element of the Structure not found 
CDBM_E_NO_MORE_RECORDS_ IN_TABTYPE 0XC004C82C Table type 3 can contain only one record 
CDBM_E_WRITE 0XC004C82D The data in the VARIANT must be given in 

a SafeArray 
CDBM_E_WRITE_NO_PARRAY 0XC004C82E The VARIANT contains no valid [parray] 

element 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_WRITE_CANT_ ACCESS_DATA 0XC004C82F Unable to access SafeArray Data in the 

VARIANT 
CDBM_E_WRITE_DATA 0XC004C830 To write the data of this Element it must be 

given as a BSTR, or as an Array of 
VT_UI1/VT_I1 

CDBM_E_WRITE_BSTR_E1 0XC004C831 The BSTR string must have an even 
length. 

CDBM_E_WRITE_BSTR_E2 0XC004C832 The BSTR string must contain only hex 
digits (0..9 and a/A..f/F). 

CDBM_E_WRITE_CANT_ INTERPRET_ARRAY 0XC004C833 Unable to interpret data in the SafeArray. 
CDBM_E_WRITE_VT_ERROR 0XC004C834 Data type in the SafeArray is not VT_UI1 

or VT_I1. 
CDBM_E_WRITE_LENGTH 0XC004C835 Data length is invalid for write operation of 

this type. 
CDBM_WRITE_ELEMENT 0XC004C836 Element not found in the Record of the 

Table 
CDBM_MIN_MAX_ERROR 0XC004C837 Can't write data because of min underflow 

or max overflow 
CDBM_TABLE_EXIST 0XC004C838 Table already exist in the database 
CDBM_MIN_MAX_INVALID 0XC004C839 The Min value is greater than the Max 

Value 
CDBM_DEF_MIN_MAX_INVALID 0XC004C83A The Default Value is not in the range 

between the Min value and the Max Value 
CDBM_CANT_CHANGE_STRUCTURE_ 
WHILE_RECORDS_EXIST 

0XC004C83B It's not allowed to change the structure 
while Records exist in the Table 

CDBM_NEW_STRUCT_NEEDS_TYPE 0XC004C83C In a newly added structure the data type 
must be set also 

CDBM_VALUE_ERROR 0XC004C83D Range error while validating a value 
CDBM_DATATYPE_ UNSUPPORTED_IN_RCS 0XC004C83E The data type is unsupported in the RCS 

file format 
CDBM_I_COUNT_OF_TABLES_ 
EXCEEDS_RCS_RANGE 

0X4004C83F 
(Informational) 

The count of Tables exceeds the RCS 
range of Tables. This can cause problems 
if the file is downloaded to RCS Systems 

CDBM_I_COUNT_OF_TABLES_ 
EXCEEDS_OLDDBM_RANGE 

0X4004C840 
(Informational) 

The count of Tables exceeds the 
DBM32.DLL range of Tables. This can 
cause problems if the file is used with older 
Tools using the DBM32.DLL 

CDBM_UNSUPPORTED_DATATYPE_ 
IN_RCS_MODE 

0XC004C841 The Data type is not compatible with the 
old database format 

CDBM_WRITE_UNSTRUCTURED_1 0XC004C842 The data of an unstructured record can 
only be written with the 'Write' Method not 
with 'WriteElement'. 

CDBM_READ_UNSTRUCTURED_1 0XC004C843 The data of an unstructured record can 
only be read with the 'Read' Method not 
with 'ReadElement' 

CDBM_WRITE_DATA_LENGTH_ INVALID 0XC004C844 The given data length doesn’t correspond 
with the expected data length. 

CDBM_UNKNOWN_VIEW_MODE 0XC004C845 The View Mode is unknown. 
CDBM_E_DIAG_TABLE 0XC004C846 It doesn’t make much sense to add or 

delete records from a diagnostic table 
because those changes are never saved. 

CDBM_E_ADR_STRING_ERROR 0XC004C847 The given Address string doesn’t fit the 
required format of this type where all 
address bytes must be in the range 
between 0 and FF 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_ERROR_FROM_VAR_ CHANGE_TYPE 0XC004C848 Function VariantChangeType return an 

error when trying to convert the Parameter 
CDBM_E_MINERROR 0XC004C849 Error while comparing the Value with the 

lower range 
CDBM_E_MAXERROR 0XC004C84A Error while comparing the Value with the 

upper range 
CDBM_E_RANGE_ERROR 0XC004C84B Value out of Range 
CDBM_E_TABLE_TYPE1 0XC004C84C Table type 1 doesn’t have a unique record 

length over all records 
CDBM_E_TABLE_TYPE3_ ADDREC 0XC004C84D Table type 3 doesn’t allow to insert more 

than one Record 
CDBM_E_TABTYPE1 0XC004C84E It's not allowed to insert more Records 

than structure definitions in Table Type 1 
CDBM_E_TOGGLE_NOT_FOUND 0XC004C84F Could not find the string for this value in 

the list of valid toggle strings 
CDBM_E_TOGGLE_VALUE_IS_ EMPTY_STRING 0XC004C850 The toggle string for this value is empty. 
CDBM_VARIANT2BYTEARRAY_ ERROR 0XC004C851 Error during conversion of Variant to byte 

array 
CDBM_E_SET_ELEM_PROP_ DEPENDENCY 0XC004C852 The Toggle Type needs also the additional 

string and the additional number  entries in 
the Method 

CDBM_E_TABTYPE1_REC_ 
DOESNT_CORRESPOND_ WITH_ELEMENT 

0XC004C853 When reading the records of Table type 1 
elementwise the record number must 
correspond with the element number 

CDBM_TABTYPE1_NO_DATA_ 
FOUND_FOR_RECORD 

0XC004C854 When reading the records of Table type 1 
and structure definitions are present it's 
assumed that for each structure element a 
corresponding record must exist 

CDBM_E_TABTYPE1_WRITE_ 
ELEMENT_NE_RECORD 

0XC004C855 When writing the records of Table type 1 
elementwise and structure definitions are 
present it's only allowed to write the 
corresponding element number in each 
record 

CDBM_E_TABTYPE1_WRITE_ 
ELEMENT_NOT_FOUND 

0XC004C856 When writing the records of Table type 1 
with an array and structure definitions are 
present it's assumed that a corresponding 
element number of this record exist 

CDBM_I_TABLE_NAME_EXCEEDS_ 
RCS_RANGE 

0X4004C857 
(Informational) 

The Table name exceeds the maximum 
length of RCS compatible Table names 

CDBM_W_CUT_STRING 0X8004C858 
(Warning) 

The string exceeds the maximum length 
and will be limited to the maximum length 

CDBM_I_STRING_TOO_SHORT 0X4004C859 
(Informational) 

The string is below the minimum length. 
The minimum length will be reduced. 

CDBM_I_STRING_TOO_LONG 0X4004C85A 
(Informational) 

The string is exceeding the maximum. The 
maximum length will be extended. 

CDBM_E_STRING_TOO_SHORT 0XC004C85B 
(Error) 

The string is below the minimum length. 

CDBM_E_STRING_TOO_LONG 0XC004C85C 
(Error) 

The string is exceeding the maximum 
length 

CDBM_E_WRONG_TYPE_ FOR_WRITE 0XC004C85D Writing on the Element type with the given 
Data type is not implemented 

CDBM_E_NO_APPEND_IN_ 
STRUCTURED_RECORDS 

0XC004C85E Method IDbmRecord::AppendData is not 
allowed for structured records 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_DATA_UNAVAILABLE 0XC004C85F No data available 
CDBM_E_CANT_CONVERT_ INTO 0XC004C860 Unable to convert the value into the 

Element type 
CDBM_E_DBM_FILE_OVERFLOW 0XC004C861 You try to write a RCS like database which 

needs too much bytes 
CDBM_E_PW_ERROR 0XC004C862 Password not correct 
CDBM_E_FILELENGTH_CORRUPT 0XC004C863 The file length doesn’t correspond to the 

length given in the Header. 
CDBM_E_STRUCT_TYPE 0XC004C864 Error in the file. 
CDBM_E_MD5SUM_INVALID 0XC004C865 MD5 sum invalid 
CDBM_E_STRUCT_LENGTH 0XC004C866 Error in the expected and given structure 

length at a specific offset in the file. 
CDBM_E_APPEND 0XC004C867 Append of data is only allowed if the 

Record contains only one data field and 
the field type will support this 

CDBM_APPEND_NOT_ SUPPORTED 0XC004C868 Append of Data not supported by this filed 
type 

CDBM_DATA_TYPE_APPEND_ ERROR 0XC004C869 Can't append Data of this type. 
CDBM_E_UNSTRUCTURED_TABLE_ 
DOESNT_SUPPORT_LENGTH 

0XC004C86A A Table without structure information 
doesn’t support a record length 

CDBM_E_DISABLED_WHILE_ 
TRANSACTION_IS_OPEN 

0XC004C86B The Method is disabled while a transaction 
is open. Please close this one first and call 
the Method again. 

CDBM_E_UNABLE_TO_CALL_ 
READ_ON_LINKED_LIST 

0XC004C86C The Method is disabled on a LinkedList 
type. Please use the IRecordCollection on 
this type. 

CDBM_E_ELEMENT_HAS_NO_ 
SUBSTRUCTURE 

0XC004C86D An Element from a Table has no 
substructure 

CDBM_STRUCT_ERROR_FROM_ 
VAR_CHANGE_TYPE 

0XC004C86E Error from calling VariantChangeType 

CDBM_E_FOREIGNKEY_DEF 0XC004C86F The definition of a FOREIGNKEY must 
contain the name of the related Table in 
the description and this Table must exist at 
this time 

CDBM_E_FOREIGNKEY_ REF_TAB 0XC004C870 The description of a FOREIGNKEY must 
refer to a Table of type 
'eDbmTableTypeLinkedList' 

CDBM_E_KEY 0XC004C871 To create a Record Collection with a KEY 
it's necessary to have the data type KEY at 
the first position in all Records of the 
searched Table 

CDBM_E_KEY_TABLE_TYPE 0XC004C872 This Method needs a Table of type 
'eDbmTableTypeLinkedList' 

CDBM_DATATYPE_NOT_ IMPLEMENTED 0XC004C873 This data type is currently not implemented 
CDBM_INSERT_POS_NOT_ FOUND 0XC004C874 The position of the Record where the new 

one should be inserted wasn’t found 

CDBM_E_INSERT_REC_QI 0XC004C875 Error during insertion of a Record 
CDBM_E_TAB_PROP 0XC004C876 Invalid Property in Table 
CDBM_E_KEY_NOT_FOUND 0XC004C877 The KEY wasn’t found in the Table 
CDBM_E_KEY_INVALID 0XC004C878 The KEY is invalid for this operation 

Table 66: ODM Error Codes DBM V4 
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12 Appendix 
12.1 User Rights 

User-rights are set within the FDT-container. Depending on the level the 
configuration is accessible by the user or read-only. 

To access the Settings, Configuration, Device Description and 
Diagnosis panes of the EtherCAT Slave DTM you do not need special 
user rights. Also all users can select the decimal or hexadecimal Display 
mode or sort table entries. 
 

 
Note: To edit, set or configure the parameters of the Settings and 
Configuration panes, you need user rights for Maintenance, for Planning 
Engineer or for Administrator. 

 

The Device Description panes do not contain any editable elements. The 
indicated values in are only for information purposes. 

The following tables give an overview of the user right groups and which 
user rights you need to configure the single parameters. 
 

12.1.1 Settings 
 Observer Operator Maintenanc

e 
Planning 
Engineer 

Adminis-
trator 

Driver D D X X X 
 Verify or adapt Driver Settings  - - X X X 
 Configuring netX Driver - - X X X 
Device Assignment D D X X X 
 Scanning for Devices - - X X X 
Selecting the Device (with or 
without firmware) 

- - X X X 

Selecting the Device once more 
(with Firmware) 

- - X X X 

Firmware Download D D X X X 

Table 67: Settings  (D = Displaying, X = Editing, Configuring) 

 
 

12.1.2 Configuration 
 Observer Operator Maintenanc

e 
Planning 
Engineer 

Administra
tor 

General D D X X X 
General Settings D D X X X 
Behavior D D X X X 
Mailbox D D X X X 

Table 68: Configuration (D = Displaying, X = Editing, Configuring) 
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12.5 Glossary 
CoE 

CANopen over EtherCAT 

CoE denominates a method for accessing an object dictionary which has 
been adopted for use in EtherCAT from CANopen. 

DDF 

Device Description File. 

DTM 

Device Type Manager. 

The Device Type Manager (DTM) is a software module with graphical user 
interface for the configuration or for diagnosis of devices. 

E²PROM 

Electronically erasable Programmable Read-Only Memory 

E-Bus 

Bus system based on LVDS standard (specified in the ANSI/TIA/EIA-644-
1995 standard) 

EDS 

Electronic Data Sheet 

 

EtherCAT-Master 

A device which is responsible for the configuration, parameterization of the 
EtherCAT segment, all connected devices’ controllers, and cyclic process 
data exchange, mailbox and diagnostics services. 

EtherCAT-Port 

Physical type of data transmission used by EtherCAT. An EtherCAT Slave 
Controller can have up to 4 EtherCAT ports. Can be one of the following 
three alternatives: 

• E-Bus 

• 100Base-TX 

• 100Base-FX 

EtherCAT-Slave 

A device which is configured by the Master, receives telegrams with output 
data, commands from it and provides input and status data. 

FDT 

Field Device Tool 

FDT specifies an interface, in order to be able to use DTM (Device Type 
Manager) in different applications of different manufacturers 
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FMMU 

Fieldbus Memory Management Unit  

A FMMU organizes the mapping of logical EtherCAT addresses to physical 
addresses. 

LVDS 

Low Voltage Differential Signals 

A data transmission standard specified in ANSI/TIA/EIA-644-1995 and 
used in Beckhoff’s E-Bus. 

Object Dictionary 

An object dictionary is a storage area for device parameter data structures. 
It is accessed in standardized manner very similarly as this is done in 
CANopen.  

ODMV3 

The Online-Data-Manager Version 3 (ODMV3) is an application interface. 
The ODMV3 works as a server, which can be run as an out-proc server or 
system service. Its task is to provide different applications (e. g. 
SYCON.net), access to multiple devices and even share one device 
amongst several applications. 

PDO 

Process Data Object 

Specific data object for cyclic data communication. 

SDO 

Service Data Object 

Specific data object for acyclic data communication, i.e. mailbox-based 
communication. It is typically used for accessing the object dictionary. 

Sync Manager 

Synchronization Manager 

A sync manager synchronizes the data communication on a specific 
communication channel. It is configured for managing either input or output 
and for working either cyclically or acyclically based on mailboxes. 
Configuration is done within the DDF file. Up to 4 sync managers numbered 
0 to 3 can be configured. 

XML 

Extensible Markup Language 

A versatile data storage format defined by the World Wide Web Consortium 
(W3C). It is based on elements and attributes. In EtherCAT, it is used in 
device descriptions stored in DDF files. 
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